summaryrefslogtreecommitdiff
path: root/app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild')
-rw-r--r--app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild b/app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild
new file mode 100644
index 000000000000..01eab6cdde7d
--- /dev/null
+++ b/app-crypt/hmaccalc/hmaccalc-0.9.14.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit multilib-minimal
+
+DESCRIPTION="Tools for computing and checking HMAC values for files"
+HOMEPAGE="https://fedorahosted.org/hmaccalc/"
+SRC_URI="https://fedorahosted.org/released/hmaccalc/hmaccalc-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fips"
+
+DEPEND="dev-libs/nss
+ sys-devel/prelink"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --enable-sum-directory=/usr/$(get_libdir)/${PN}/ \
+ $(use_enable !fips non-fips)
+}