summaryrefslogtreecommitdiff
path: root/app-crypt/gpgme/gpgme-1.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpgme/gpgme-1.10.0.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-1.10.0.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/app-crypt/gpgme/gpgme-1.10.0.ebuild b/app-crypt/gpgme/gpgme-1.10.0.ebuild
index 110e0e94550b..8aebc92fc119 100644
--- a/app-crypt/gpgme/gpgme-1.10.0.ebuild
+++ b/app-crypt/gpgme/gpgme-1.10.0.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="1/11" # subslot = soname major version
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="common-lisp static-libs cxx python qt5"
COMMON_DEPEND=">=app-crypt/gnupg-2
@@ -44,15 +44,14 @@ do_python() {
fi
}
-pkg_pretend() {
- local MAX_WORKDIR=66
-
- [[ "${#WORKDIR}" -le "${MAX_WORKDIR}" ]] ||
- die "Cannot build package as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail build"
-}
-
pkg_setup() {
addpredict /run/user/$(id -u)/gnupg
+
+ local MAX_WORKDIR=66
+ if [[ "${#WORKDIR}" -gt "${MAX_WORKDIR}" ]]; then
+ ewarn "Disabling tests as WORKDIR '${WORKDIR}' is longer than ${MAX_WORKDIR} which will fail tests"
+ SKIP_TESTS=1
+ fi
}
src_prepare() {
@@ -76,6 +75,7 @@ src_configure() {
fi
econf \
+ $([[ -n "${SKIP_TESTS}" ]] && echo "--disable-gpg-test --disable-gpgsm-test") \
--enable-languages="${languages[*]}" \
$(use_enable static-libs static)
@@ -90,6 +90,8 @@ src_compile() {
}
src_test() {
+ [[ -z "${SKIP_TESTS}" ]] || return
+
default
if use python; then
test_python() {