summaryrefslogtreecommitdiff
path: root/app-crypt/gpa/gpa-0.10.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gpa/gpa-0.10.0.ebuild')
-rw-r--r--app-crypt/gpa/gpa-0.10.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-crypt/gpa/gpa-0.10.0.ebuild b/app-crypt/gpa/gpa-0.10.0.ebuild
new file mode 100644
index 000000000000..b2e65c08bdac
--- /dev/null
+++ b/app-crypt/gpa/gpa-0.10.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The GNU Privacy Assistant (GPA) is a graphical user interface for GnuPG"
+HOMEPAGE="http://gpa.wald.intevation.org"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="
+ >=app-crypt/gnupg-2:=
+ >=app-crypt/gpgme-1.11.1:=
+ >=dev-libs/libassuan-1.1.0:=
+ >=dev-libs/libgpg-error-1.4:=
+ >=x11-libs/gtk+-2.10.0:2=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+ sed -i 's/Application;//' gpa.desktop
+}
+
+src_configure() {
+ econf \
+ --with-gpgme-prefix=/usr \
+ --with-libassuan-prefix=/usr \
+ $(use_enable nls) \
+ GPGKEYS_LDAP="/usr/libexec/gpgkeys_ldap"
+}