summaryrefslogtreecommitdiff
path: root/app-crypt/glep63-check/glep63-check-8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/glep63-check/glep63-check-8.ebuild')
-rw-r--r--app-crypt/glep63-check/glep63-check-8.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/glep63-check/glep63-check-8.ebuild b/app-crypt/glep63-check/glep63-check-8.ebuild
new file mode 100644
index 000000000000..13996cabd8a0
--- /dev/null
+++ b/app-crypt/glep63-check/glep63-check-8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="GLEP 63 compliance checker for OpenPGP keys"
+HOMEPAGE="https://github.com/mgorny/glep63-check/"
+SRC_URI="https://github.com/mgorny/glep63-check/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ sys-libs/libfaketime
+ )"
+
+python_test() {
+ "${EPYTHON}" -m unittest -v || die "Tests fail with ${EPYTHON}"
+}