summaryrefslogtreecommitdiff
path: root/app-crypt/glep63-check/glep63-check-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/glep63-check/glep63-check-1.ebuild')
-rw-r--r--app-crypt/glep63-check/glep63-check-1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-crypt/glep63-check/glep63-check-1.ebuild b/app-crypt/glep63-check/glep63-check-1.ebuild
new file mode 100644
index 000000000000..1ffa43933fbc
--- /dev/null
+++ b/app-crypt/glep63-check/glep63-check-1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit python-single-r1
+
+DESCRIPTION="GLEP 63 compliance checker for OpenPGP keys"
+HOMEPAGE="https://github.com/mgorny/glep63-check/"
+SRC_URI="https://github.com/mgorny/glep63-check/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ app-crypt/gnupg"
+
+src_compile() {
+ python_fix_shebang glep63-check
+}
+
+src_install() {
+ dobin glep63-check
+}