summaryrefslogtreecommitdiff
path: root/app-crypt/eid-mw/eid-mw-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/eid-mw/eid-mw-9999.ebuild')
-rw-r--r--app-crypt/eid-mw/eid-mw-9999.ebuild32
1 files changed, 6 insertions, 26 deletions
diff --git a/app-crypt/eid-mw/eid-mw-9999.ebuild b/app-crypt/eid-mw/eid-mw-9999.ebuild
index f514363c71c1..67d72f68ad1e 100644
--- a/app-crypt/eid-mw/eid-mw-9999.ebuild
+++ b/app-crypt/eid-mw/eid-mw-9999.ebuild
@@ -13,19 +13,19 @@ LICENSE="LGPL-3"
SLOT="0"
IUSE="+dialogs +gtk p11-kit"
-RDEPEND=">=sys-apps/pcsc-lite-1.2.9
+RDEPEND="sys-apps/pcsc-lite
gtk? (
x11-libs/gdk-pixbuf[jpeg]
x11-libs/gtk+:3
dev-libs/libxml2
net-misc/curl[ssl]
net-libs/libproxy
- >=app-crypt/pinentry-1.1.0-r4[gtk]
+ app-crypt/pinentry[gtk]
)
p11-kit? ( app-crypt/p11-kit )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
REQUIRED_USE="dialogs? ( gtk )"
@@ -43,20 +43,6 @@ src_prepare() {
-e "s:get_lsb_info('c'):strdup(_(\"n/a\")):" \
plugins_tools/aboutmw/gtk/about-main.c || die
- # Fix libdir for manifestdir
- sed -i \
- -e "/pkcs11_manifestdir/ s:prefix)/lib:libdir):" \
- -e "/managed_storage_manifestdir/ s:prefix)/lib:libdir):" \
- cardcomm/pkcs11/src/Makefile.am || die
-
- # See bug #732994
- sed -i \
- -e '/LDFLAGS="/ s:$CPPFLAGS:$LDFLAGS:' \
- configure.ac || die
-
- # See bug #751472
- eapply "${FILESDIR}/use-printf-in-Makefile.patch"
-
# See bug #811270 (remove uml build)
sed -i \
-e 's:cardlayer/uml::' \
@@ -65,11 +51,6 @@ src_prepare() {
-e 's:uml::' \
plugins_tools/eid-viewer/Makefile.am || die
- # See bug #923375
- sed -i \
- -e 's:C_Sign(NULL,:C_Sign(NULL_PTR,:' \
- tests/unit/sign_state.c || die
-
eautoreconf
}
@@ -77,9 +58,8 @@ src_configure() {
econf \
$(use_enable dialogs) \
$(use_enable p11-kit p11kit) \
- $(use_with gtk gtkvers 'detect') \
- --with-gnu-ld \
- --disable-static
+ $(use_with gtk gtkvers '3') \
+ --with-gnu-ld
}
src_install() {