summaryrefslogtreecommitdiff
path: root/app-crypt/easy-rsa/easy-rsa-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/easy-rsa/easy-rsa-3.0.3.ebuild')
-rw-r--r--app-crypt/easy-rsa/easy-rsa-3.0.3.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/app-crypt/easy-rsa/easy-rsa-3.0.3.ebuild b/app-crypt/easy-rsa/easy-rsa-3.0.3.ebuild
deleted file mode 100644
index 5604cb713a69..000000000000
--- a/app-crypt/easy-rsa/easy-rsa-3.0.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils
-
-MY_P="EasyRSA-${PV}"
-
-DESCRIPTION="Small RSA key management package, based on OpenSSL"
-HOMEPAGE="https://openvpn.net/"
-SRC_URI="https://github.com/OpenVPN/easy-rsa/releases/download/v${PV}/${MY_P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="libressl"
-
-DEPEND="!libressl? ( >=dev-libs/openssl-0.9.6:0 )
- libressl? ( dev-libs/libressl )"
-RDEPEND="${DEPEND}
- !<net-vpn/openvpn-2.3"
-
-S="${WORKDIR}/${MY_P}"
-
-src_install() {
- exeinto /usr/share/easy-rsa
- doexe easyrsa
- insinto /usr/share/easy-rsa
- doins -r vars.example openssl-1.0.cnf x509-types
- dodoc README.quickstart.md ChangeLog
- dodoc -r doc
- doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
-}