summaryrefslogtreecommitdiff
path: root/app-crypt/codecrypt/codecrypt-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/codecrypt/codecrypt-1.7.2.ebuild')
-rw-r--r--app-crypt/codecrypt/codecrypt-1.7.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/codecrypt/codecrypt-1.7.2.ebuild b/app-crypt/codecrypt/codecrypt-1.7.2.ebuild
new file mode 100644
index 000000000000..4b370f10bca4
--- /dev/null
+++ b/app-crypt/codecrypt/codecrypt-1.7.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Post-quantum cryptography tool"
+HOMEPAGE="http://e-x-a.org/codecrypt/"
+SRC_URI="http://e-x-a.org/codecrypt/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+cryptopp"
+
+DEPEND="dev-libs/gmp:=
+ cryptopp? ( dev-libs/crypto++ )
+ sci-libs/fftw:3.0"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+ # workaround -- gentoo is missing crypto++ pkg-config file
+ sed -i -e 's/PKG_CHECK_MODULES(\[CRYPTOPP\],.*/LDFLAGS="$LDFLAGS -lcrypto++"/' configure.ac
+ ./autogen.sh
+}
+
+src_configure() {
+ econf \
+ $(use_with cryptopp )
+}