summaryrefslogtreecommitdiff
path: root/app-crypt/certbot
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/Manifest2
-rw-r--r--app-crypt/certbot/certbot-2.10.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index f3e331b00435..4dc3916870f0 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,5 +1,7 @@
+DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
+EBUILD certbot-2.10.0.ebuild 1546 BLAKE2B ed814bef37abf0ac6bace3221cdbbfae65935c0e940cc0398e255efcd883196fd0053a6f8247b45d9c51bf60efee0d22b7f82cdc7c89f1a63c31377bc3156693 SHA512 cbb3251362235bb2ff54349a6732f0cb68e70f03c1db1f691080cb8a207c815d7d7ff97e846836cdc3f27e4765e0f5369851c291b23da9064aec90bbb955b126
EBUILD certbot-2.8.0.ebuild 1542 BLAKE2B ae50a268d1cf78da60ec04063d8c6df338e96cae6c0fb457401d69e3f63c9f4640d12bb9f5d157cd50e1a098a0d998d4f788399348daa21a8a9cde8bc270a39c SHA512 63f065d7ce851f5774d64946708fee5234adc6e3f97995b7381f7d6d3ed917611b69223b30ec8d061a91fd4ece70ecc42544f50de08c6779219564eb5c12e487
EBUILD certbot-2.9.0.ebuild 1542 BLAKE2B ae50a268d1cf78da60ec04063d8c6df338e96cae6c0fb457401d69e3f63c9f4640d12bb9f5d157cd50e1a098a0d998d4f788399348daa21a8a9cde8bc270a39c SHA512 63f065d7ce851f5774d64946708fee5234adc6e3f97995b7381f7d6d3ed917611b69223b30ec8d061a91fd4ece70ecc42544f50de08c6779219564eb5c12e487
EBUILD certbot-9999.ebuild 1546 BLAKE2B ed814bef37abf0ac6bace3221cdbbfae65935c0e940cc0398e255efcd883196fd0053a6f8247b45d9c51bf60efee0d22b7f82cdc7c89f1a63c31377bc3156693 SHA512 cbb3251362235bb2ff54349a6732f0cb68e70f03c1db1f691080cb8a207c815d7d7ff97e846836cdc3f27e4765e0f5369851c291b23da9064aec90bbb955b126
diff --git a/app-crypt/certbot/certbot-2.10.0.ebuild b/app-crypt/certbot/certbot-2.10.0.ebuild
new file mode 100644
index 000000000000..987d94f3776a
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.10.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest