summaryrefslogtreecommitdiff
path: root/app-crypt/argon2/argon2-20161029-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/argon2/argon2-20161029-r1.ebuild')
-rw-r--r--app-crypt/argon2/argon2-20161029-r1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/app-crypt/argon2/argon2-20161029-r1.ebuild b/app-crypt/argon2/argon2-20161029-r1.ebuild
deleted file mode 100644
index 1af92a371835..000000000000
--- a/app-crypt/argon2/argon2-20161029-r1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit multilib
-
-DESCRIPTION="Password hashing software that won the Password Hashing Competition (PHC)"
-HOMEPAGE="https://github.com/P-H-C/phc-winner-argon2"
-SRC_URI="https://github.com/P-H-C/phc-winner-argon2/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 CC0-1.0 )"
-SLOT="0/0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="static-libs"
-
-S="${WORKDIR}/phc-winner-${P}"
-PATCHES=(
- "${FILESDIR}/${P}-makefile-soname-symlinks.patch"
- )
-src_prepare() {
- default
- if ! use static-libs; then
- sed -i -e 's/LIBRARIES = \$(LIB_SH) \$(LIB_ST)/LIBRARIES = \$(LIB_SH)/' Makefile || die "sed failed!"
- fi
- sed -i -e 's/-O3 //' Makefile || die "sed failed"
- sed -i -e 's/-g //' Makefile || die "sed failed"
- sed -i -e "s/-march=\$(OPTTARGET) /${CFLAGS} /" Makefile || die "sed failed"
- sed -i -e 's/CFLAGS += -march=\$(OPTTARGET)//' Makefile || die "sed failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" LIBRARY_REL=$(get_libdir) install || die
-}