summaryrefslogtreecommitdiff
path: root/app-containers
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/Manifest.gzbin8878 -> 8883 bytes
-rw-r--r--app-containers/podman-tui/Manifest4
-rw-r--r--app-containers/podman-tui/podman-tui-0.12.0.ebuild37
-rw-r--r--app-containers/podman-tui/podman-tui-9999.ebuild7
4 files changed, 45 insertions, 3 deletions
diff --git a/app-containers/Manifest.gz b/app-containers/Manifest.gz
index df37e1b3cb0f..fc2a263abf2c 100644
--- a/app-containers/Manifest.gz
+++ b/app-containers/Manifest.gz
Binary files differ
diff --git a/app-containers/podman-tui/Manifest b/app-containers/podman-tui/Manifest
index 396b247a9b86..fd4ff3399e77 100644
--- a/app-containers/podman-tui/Manifest
+++ b/app-containers/podman-tui/Manifest
@@ -1,4 +1,6 @@
DIST podman-tui-0.11.0.tar.gz 13317542 BLAKE2B 0492799b7e61eaa75344392d824be6f41bac0b61510587cca936ec2e5f516e2513e709d739e66cd86a658fa916f61a02dbf0802a3761bab2ccb11705c3d514f3 SHA512 1b5ce216829a0f2ef345920ea908a5f721ee704bf3c7efe121e42c413edb84fb247eb32964fcd7928c734df93efd85a3c1fb5a92b0e6f3c1de3b4906fbc77fe2
+DIST podman-tui-0.12.0.tar.gz 15740756 BLAKE2B 2d38997e6ffc67d8d4f2e8c68856b4da4eb3b658ab5998da752b5d01a7d7591d3f196efba11f9d6d67bf438335729ea7bcab920eb1e2e847f6a024c3f4b3ebed SHA512 753932fef58746c80752c142aae17ef61b4632af51f8d9bd5aee29246ffc8179f98f4e38c7607a82efd25d0b809e9065a5b537b1a3a823eabae23a87b5b6dd74
EBUILD podman-tui-0.11.0.ebuild 856 BLAKE2B 47af4841fc6d3ff7df20df273d21bf6fde9b075a4962651e11c8fd395014a5e65729a569eb52f124b8ec4f4286a88cf7e7043bba2437dfdc22ed9c40addf2166 SHA512 c9e18fbc8d2db7c7e7431349e7ae64b7555ffc5c93342adad47815f2bc73a6856946e73ae85ddbe38f7b73e73a9854262a18dbef2500e397ae0df354638e1d77
-EBUILD podman-tui-9999.ebuild 856 BLAKE2B 47af4841fc6d3ff7df20df273d21bf6fde9b075a4962651e11c8fd395014a5e65729a569eb52f124b8ec4f4286a88cf7e7043bba2437dfdc22ed9c40addf2166 SHA512 c9e18fbc8d2db7c7e7431349e7ae64b7555ffc5c93342adad47815f2bc73a6856946e73ae85ddbe38f7b73e73a9854262a18dbef2500e397ae0df354638e1d77
+EBUILD podman-tui-0.12.0.ebuild 885 BLAKE2B 9d44c2616057549c8e33ea7b74bab6a48a9908447023d7cdd767c01e2b5850a72017007334d771bfef1835315f7d5d7642971e77c6089e976d92ab871bcf9ac9 SHA512 c654bdbdd43731f4d1b92308d9f2bf454a85a77651fb88f573d7e22c68bbd40d211ed104acc9fd5378744cb2df0b9075213409f93d3f55d57503798da6ad6b71
+EBUILD podman-tui-9999.ebuild 885 BLAKE2B 9d44c2616057549c8e33ea7b74bab6a48a9908447023d7cdd767c01e2b5850a72017007334d771bfef1835315f7d5d7642971e77c6089e976d92ab871bcf9ac9 SHA512 c654bdbdd43731f4d1b92308d9f2bf454a85a77651fb88f573d7e22c68bbd40d211ed104acc9fd5378744cb2df0b9075213409f93d3f55d57503798da6ad6b71
MISC metadata.xml 627 BLAKE2B ec60583d8d1b2800e3635b3f84dc5763a2349bb80306360b24389107e486947dae8bf25aecd57ece7700bce16eb9b6ccaf1bf27c119b98c6dd8ee431a77f7ebb SHA512 b6f180e33ee4c85df17aa49a4768802b8d890443b63d37b3536ccada9a7c2946f365c943bc0eb5fffe6225121dfafc3935b70fce376ec9c4c662ddf8b060ceb2
diff --git a/app-containers/podman-tui/podman-tui-0.12.0.ebuild b/app-containers/podman-tui/podman-tui-0.12.0.ebuild
new file mode 100644
index 000000000000..2effb9e6c06b
--- /dev/null
+++ b/app-containers/podman-tui/podman-tui-0.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+DESCRIPTION="Terminal UI frontend for Podman"
+HOMEPAGE="https://github.com/containers/podman-tui"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
+else
+ SRC_URI="https://github.com/containers/podman-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD-2 BSD MIT MPL-2.0"
+SLOT="0"
+RESTRICT="test"
+RDEPEND="
+ >=app-containers/podman-4.0.2
+"
+
+src_compile() {
+ # parse tags from Makefile & make them comma-seperated as space-seperated list is deprecated
+ local BUILDTAGS=$(grep 'BUILDTAGS :=' Makefile | awk -F\" '{ print $2; }' | sed -e 's| |,|g;')
+ ego build -tags "${BUILDTAGS}"
+}
+
+src_install() {
+ dobin "${PN}"
+ einstalldocs
+}
diff --git a/app-containers/podman-tui/podman-tui-9999.ebuild b/app-containers/podman-tui/podman-tui-9999.ebuild
index 58c2601964d0..2effb9e6c06b 100644
--- a/app-containers/podman-tui/podman-tui-9999.ebuild
+++ b/app-containers/podman-tui/podman-tui-9999.ebuild
@@ -7,7 +7,7 @@ inherit go-module
DESCRIPTION="Terminal UI frontend for Podman"
HOMEPAGE="https://github.com/containers/podman-tui"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/podman-tui.git"
else
@@ -15,7 +15,10 @@ else
KEYWORDS="~amd64"
fi
-LICENSE="Apache-2.0 BSD-2 BSD MIT MPL-2.0"
+# main pkg
+LICENSE="Apache-2.0"
+# deps
+LICENSE+=" BSD-2 BSD MIT MPL-2.0"
SLOT="0"
RESTRICT="test"
RDEPEND="