summaryrefslogtreecommitdiff
path: root/app-containers/lxd/files/lxd-5.17-remove-shellcheck-buildsystem-checks.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/lxd/files/lxd-5.17-remove-shellcheck-buildsystem-checks.patch')
-rw-r--r--app-containers/lxd/files/lxd-5.17-remove-shellcheck-buildsystem-checks.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-containers/lxd/files/lxd-5.17-remove-shellcheck-buildsystem-checks.patch b/app-containers/lxd/files/lxd-5.17-remove-shellcheck-buildsystem-checks.patch
new file mode 100644
index 000000000000..b0e3a7500b89
--- /dev/null
+++ b/app-containers/lxd/files/lxd-5.17-remove-shellcheck-buildsystem-checks.patch
@@ -0,0 +1,31 @@
+--- a/Makefile
++++ b/Makefile
+@@ -249,28 +249,6 @@ endif
+ .PHONY: build-mo
+ build-mo: $(MOFILES)
+
+-.PHONY: static-analysis
+-static-analysis:
+-ifeq ($(shell command -v golangci-lint),)
+- curl -sSfL https://raw.githubusercontent.com/golangci/golangci-lint/master/install.sh | sh -s -- -b $$(go env GOPATH)/bin
+-endif
+-ifeq ($(shell command -v shellcheck),)
+- echo "Please install shellcheck"
+- exit 1
+-endif
+-ifneq "$(shell shellcheck --version | grep version: | cut -d ' ' -f2)" "0.8.0"
+- @echo "WARN: shellcheck version is not 0.8.0"
+-endif
+-ifeq ($(shell command -v flake8),)
+- echo "Please install flake8"
+- exit 1
+-endif
+- golangci-lint run --timeout 5m
+- flake8 test/deps/import-busybox
+- shellcheck --shell sh test/*.sh test/includes/*.sh test/suites/*.sh test/backends/*.sh test/lint/*.sh
+- shellcheck test/extras/*.sh
+- run-parts --exit-on-error --regex '.sh' test/lint
+-
+ .PHONY: tags
+ tags: *.go lxd/*.go shared/*.go lxc/*.go
+ find . -type f -name '*.go' | xargs gotags > tags