summaryrefslogtreecommitdiff
path: root/app-containers/devcontainer/devcontainer-0.56.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/devcontainer/devcontainer-0.56.0.ebuild')
-rw-r--r--app-containers/devcontainer/devcontainer-0.56.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-containers/devcontainer/devcontainer-0.56.0.ebuild b/app-containers/devcontainer/devcontainer-0.56.0.ebuild
deleted file mode 100644
index 10d7f50fc167..000000000000
--- a/app-containers/devcontainer/devcontainer-0.56.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Reference implementation of the Development Containers specification"
-HOMEPAGE="https://containers.dev/
- https://github.com/devcontainers/cli/"
-SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
- -> ${P}.tgz"
-S="${WORKDIR}/package"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-RDEPEND="
- net-libs/nodejs
-"
-BDEPEND="
- >=net-libs/nodejs-16[npm]
-"
-
-DOCS=( CHANGELOG.md README.md )
-
-src_compile() {
- # Skip, nothing to compile here.
- :
-}
-
-src_install() {
- local -a my_npm_opts=(
- --audit false
- --color false
- --foreground-scripts
- --global
- --offline
- --omit dev
- --prefix "${ED}/usr"
- --progress false
- --verbose
- )
- npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
-
- einstalldocs
-}