summaryrefslogtreecommitdiff
path: root/app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch')
-rw-r--r--app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch b/app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch
new file mode 100644
index 000000000000..15cdc7511136
--- /dev/null
+++ b/app-containers/cosign/files/cosign-1.5.0-fix-makefile.patch
@@ -0,0 +1,13 @@
+--- a/Makefile 2022-01-22 16:06:02.000000000 -0500
++++ b/Makefile 2022-01-27 15:06:43.986094208 -0500
+@@ -71,8 +71,8 @@
+ checkfmt: SHELL := /usr/bin/env bash
+ checkfmt: ## Check formatting of all go files
+ @ $(MAKE) --no-print-directory log-$@
+- $(shell test -z "$(shell gofmt -l $(GOFILES) | tee /dev/stderr)")
+- $(shell test -z "$(shell goimports -l $(GOFILES) | tee /dev/stderr)")
++ $(shell test -z "$(shell gofmt -l $(GOFILES) | tee /dev/stderr)")
++ $(shell test -z "$(shell goimports -l $(GOFILES) | tee /dev/stderr)")
+
+ .PHONY: fmt
+ fmt: ## Format all go files