summaryrefslogtreecommitdiff
path: root/app-containers/containers-common/containers-common-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/containers-common/containers-common-9999.ebuild')
-rw-r--r--app-containers/containers-common/containers-common-9999.ebuild29
1 files changed, 22 insertions, 7 deletions
diff --git a/app-containers/containers-common/containers-common-9999.ebuild b/app-containers/containers-common/containers-common-9999.ebuild
index c4d53773f1d9..4a0427e20df7 100644
--- a/app-containers/containers-common/containers-common-9999.ebuild
+++ b/app-containers/containers-common/containers-common-9999.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit readme.gentoo-r1
+
DESCRIPTION="Common config files and docs for Containers stack"
HOMEPAGE="https://github.com/containers/common"
@@ -19,16 +21,16 @@ LICENSE="Apache-2.0"
SLOT="0"
RESTRICT="test"
RDEPEND="
- app-containers/containers-image
- app-containers/containers-storage
+ >=app-containers/aardvark-dns-1.10.0
+ >=app-containers/crun-1.14.3
+ >=app-containers/containers-image-5.30.0
+ >=app-containers/containers-storage-1.53.0
app-containers/containers-shortnames
+ >=app-containers/netavark-1.10.3
net-firewall/nftables
net-firewall/iptables[nftables]
- || ( app-containers/crun app-containers/runc )
- || (
- ( >=app-containers/netavark-1.6.0 >=app-containers/aardvark-dns-1.6.0 )
- >=app-containers/cni-plugins-0.9.1
- )
+ >=net-misc/passt-2024.03.20
+ >=sys-fs/fuse-overlayfs-1.13
"
BDEPEND="
@@ -39,6 +41,14 @@ PATCHES=(
"${FILESDIR}/examplify-mounts-conf.patch"
)
+DOC_CONTENTS="\n
+For rootless operations, one needs to configure subuid(5) and subgid(5)\n
+See /etc/sub{uid,gid} to check whether rootless user is already configured\n
+If not, quickly configure it with:\n
+usermod --add-subuids 1065536-1131071 <rootless user>\n
+usermod --add-subgids 1065536-1131071 <rootless user>\n
+"
+
src_prepare() {
default
@@ -52,9 +62,14 @@ src_compile() {
src_install() {
emake DESTDIR="${ED}" install
+ readme.gentoo_create_doc
insinto /usr/share/containers
doins pkg/seccomp/seccomp.json pkg/subscriptions/mounts.conf
keepdir /etc/containers/certs.d /etc/containers/oci/hooks.d /etc/containers/systemd /var/lib/containers/sigstore
}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}