summaryrefslogtreecommitdiff
path: root/app-cdr/uif2iso
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/uif2iso')
-rw-r--r--app-cdr/uif2iso/Manifest5
-rw-r--r--app-cdr/uif2iso/metadata.xml5
-rw-r--r--app-cdr/uif2iso/uif2iso-0.1.7c-r1.ebuild41
3 files changed, 51 insertions, 0 deletions
diff --git a/app-cdr/uif2iso/Manifest b/app-cdr/uif2iso/Manifest
new file mode 100644
index 000000000000..718a1598acf1
--- /dev/null
+++ b/app-cdr/uif2iso/Manifest
@@ -0,0 +1,5 @@
+DIST uif2iso-0.1.7c.zip 113727 BLAKE2B ae82e898cf27da8e3283af4c3d8dc2bea87fe29fbe998cf720f7876665c621495b1f68ab28af1250d7d041640404fc3d04c112eb7599476dfe4cb8118ab1dad9 SHA512 22e2e2d156cae7f2f72ba5959bf3b4282609397d148e6a98666382003ce568e185a90e6af8821829d302c1efea1ca2c6d155df0181c6a29294d70de8adc9591f
+DIST uif2iso-test.iso 55296 BLAKE2B b17ea40509445665c9103b38fcf26fd8b6e84917e9a0d31c7a53bbb201c310685649c06d055454dc2883e1d566d98912003d74ffbb68f6e6dca8dd47c1705a59 SHA512 775f8fc87a51709c6ef10ae2751cc8600c22d70af419afd680a1917338a699e6a3934597af26400f67ff68fdea5db32e416d73fda370ef71f0d19a5bbdcbedd6
+DIST uif2iso-test.uif 499 BLAKE2B 8e5098629c11572e839bc481ef44e7ff79c46926e049c3f5fb41b1868f63775f509740679835b289222299cfc9710ae8ff7f1739089a44f6fabd1d12720251fb SHA512 6863305d325ec6cf6c8693512d011ec4150bcf0be94f84495e4075cea74412b9fd8ede17f77ad9f7d4b3cf205c9406adbd5440697c7857ab094e4659d074efeb
+EBUILD uif2iso-0.1.7c-r1.ebuild 1079 BLAKE2B 850274931d547bfd444f53a24f3566073f4980ef021a1b8dd4acb4b78480b1ef83dfae9d416bf6ba8f2d6e8eba8f6c230a72c35b1b7ce8aac7a54bee0db69fbf SHA512 8ef1cbb864c6554e1dd7452ba50fea697ff55dd7c4c43a50940757f265036ae7ef9b2f2486c5ca9cb5cc82596107c7231b580153f54836a039f8af07b28a32d7
+MISC metadata.xml 165 BLAKE2B ed7e2ebe9f71491aa6163627bdb6606e798b98ca85c053b50442182a245074a9e09b290835e7c8fb4a10e4e8227c16ec306fd16f337cb66904095d864e698e8b SHA512 bebe508b4e0a7ca4a046f9befd3d7ddb702756024756a5f0d9fb5ace5fe3f5a98f9d42afda4597b7d1338607b8d43e41c8fcd6d20d31da3ebad2b420edd2cb59
diff --git a/app-cdr/uif2iso/metadata.xml b/app-cdr/uif2iso/metadata.xml
new file mode 100644
index 000000000000..58f638b2ac3e
--- /dev/null
+++ b/app-cdr/uif2iso/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!--maintainer-needed-->
+</pkgmetadata>
diff --git a/app-cdr/uif2iso/uif2iso-0.1.7c-r1.ebuild b/app-cdr/uif2iso/uif2iso-0.1.7c-r1.ebuild
new file mode 100644
index 000000000000..42e0d67928b1
--- /dev/null
+++ b/app-cdr/uif2iso/uif2iso-0.1.7c-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+inherit toolchain-funcs
+
+DESCRIPTION="Convert CD images from uif (MagicISO) to iso"
+HOMEPAGE="http://aluigi.altervista.org/mytoolz.htm#uif2iso"
+SRC_URI="mirror://gentoo/${P}.zip
+ test? ( https://yegortimoshenko.s3.amazonaws.com/${PN}-test.iso
+ https://yegortimoshenko.s3.amazonaws.com/${PN}-test.uif )"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" -C src -f - <<-'EOF'
+ CPPFLAGS += -DMAGICISO_IS_SHIT
+ LDLIBS = -lz
+ uif2iso: $(patsubst %.c,%.o,$(wildcard *.c))
+ EOF
+}
+
+src_test() {
+ einfo "checking that uif -> iso matches the expected output"
+ src/${PN} "${DISTDIR}/${PN}-test.uif" "${T}/${PN}-test.iso" # always returns 1
+ diff "${DISTDIR}/${PN}-test.iso" "${T}/${PN}-test.iso" || die "unexpected iso"
+}
+
+src_install() {
+ dobin src/${PN}
+ dodoc ${PN}.txt README
+}