summaryrefslogtreecommitdiff
path: root/app-backup/mirdir
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/mirdir')
-rw-r--r--app-backup/mirdir/Manifest2
-rw-r--r--app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch11
-rw-r--r--app-backup/mirdir/mirdir-2.1-r3.ebuild39
3 files changed, 52 insertions, 0 deletions
diff --git a/app-backup/mirdir/Manifest b/app-backup/mirdir/Manifest
index 77d8832ec4f7..f7489fa38dfc 100644
--- a/app-backup/mirdir/Manifest
+++ b/app-backup/mirdir/Manifest
@@ -1,3 +1,5 @@
+AUX mirdir-2.1-implicit-function-decl.patch 190 BLAKE2B 2071e5717bd4a5eed34ae2250f45a0760f41a01f23d79ab1bfe31434682e55a71b6429a3a0e7e5f44f13d58817220daf3ef750d4737e40c7f9d425a6b59f8ac6 SHA512 6c5302e4e9f306b354991233ec5f0dbd6b52efe524ebec0f1609f5266aa1896d6892e49b7a91d689a0ce45fc0e56d5f5f33028dd840bc0e1d2ae46a021a80e8c
DIST mirdir-2.1-Unix.tar.gz 74002 BLAKE2B e9a22bbdae1e2502ffb3bff09f56aa546b79d1847d1e2081ebb262bc9601d1e1e3e48ded45db7e6adb657d2b491b9615974a740be630a277094a66bf4bcbfeaf SHA512 d99cbc04a5d99a739c16fea9198d92cd0209fb5fd4fc931eb2af2bb6c0c0ddcec3c34a27269bf108d7ffebcf760c9817088ea2091abbe9d3c4e932724e85c680
EBUILD mirdir-2.1-r2.ebuild 532 BLAKE2B 786a3812122bc7be09799b9c2a3f0aef59e418bcec7afb9d75445cf4d02387aea8e5f2cf20521151a76c37d86c11e2f2609001917a435c74225835978cd7118f SHA512 42169eacbd465854f7ae69f0187b5bc1e6dd736d678fce77d2ae56bca1be6312e73fcc0c21e0763f75aa490d18f1139086dcd8c75e68afe8447cabf88d592736
+EBUILD mirdir-2.1-r3.ebuild 773 BLAKE2B c9d2efe6f813ce7dbaa2e103b89bfeb8c44b3b7a3bf04e2fbe8f4eb279822646ac0cbfe24925ec007b8869201f8ed5fabe8c2d7b2216ca78c7c4de3a129d4ef7 SHA512 b64b3249e64ed3af32e65902369ba5a03b926920059888e59d280920dcc438bf6bb57e087d6087dbdfeaf872ca679db3ba8b9b8390b716c7e447112434a1f9ea
MISC metadata.xml 337 BLAKE2B a144ae0e49068aa9051e9aa7a847905025152ee12959532f6e286a86477e5a309d77d540295c7440037715d190b29f26fc174ec5e8536a51a57a5db543081992 SHA512 c1100f32b7f60981768b3f71c6314a5d2aa308ba6f61d346b9f46b15f95096bb8845b62c407754ee8073b7c2fa1dd8e26cb987698e98770b3afe561d0d0491e5
diff --git a/app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch b/app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch
new file mode 100644
index 000000000000..e9e824d9f019
--- /dev/null
+++ b/app-backup/mirdir/files/mirdir-2.1-implicit-function-decl.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/854213
+--- a/mirdir.c
++++ b/mirdir.c
+@@ -88,6 +88,7 @@
+ #include <fcntl.h>
+ #include <dirent.h>
+ #include <time.h>
++#include <unistd.h>
+
+ /*
+ #include <sys/types.h>
diff --git a/app-backup/mirdir/mirdir-2.1-r3.ebuild b/app-backup/mirdir/mirdir-2.1-r3.ebuild
new file mode 100644
index 000000000000..ac0a24f319bd
--- /dev/null
+++ b/app-backup/mirdir/mirdir-2.1-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Synchronize two directory trees in a fast way"
+HOMEPAGE="https://sourceforge.net/projects/mirdir/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-Unix.tar.gz"
+S="${WORKDIR}/${P}-UNIX"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1-implicit-function-decl.patch
+)
+
+src_prepare() {
+ default
+
+ # Disable stripping, bug #239939
+ sed -i -e 's:strip .*::' Makefile.in || die
+}
+
+src_configure() {
+ # Old autoconf gets this test wrong with -flto(!) and there's
+ # no source configure.in/.ac in the tarball. bug #854213
+ export ac_cv_func_lutime=no
+
+ econf
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman ${PN}.1
+
+ einstalldocs
+}