summaryrefslogtreecommitdiff
path: root/app-backup/hdup/hdup-2.0.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/hdup/hdup-2.0.14.ebuild')
-rw-r--r--app-backup/hdup/hdup-2.0.14.ebuild66
1 files changed, 26 insertions, 40 deletions
diff --git a/app-backup/hdup/hdup-2.0.14.ebuild b/app-backup/hdup/hdup-2.0.14.ebuild
index 296408761b4c..87d941b00336 100644
--- a/app-backup/hdup/hdup-2.0.14.ebuild
+++ b/app-backup/hdup/hdup-2.0.14.ebuild
@@ -1,55 +1,41 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-KEYWORDS="~amd64 ~ppc ~x86"
+EAPI=6
+
DESCRIPTION="Hdup is backup program using tar, find, gzip/bzip2, mcrypt and ssh"
HOMEPAGE="http://www.miek.nl/projects/hdup2/index.html"
SRC_URI="http://www.miek.nl/projects/${PN}2/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="crypt"
-CDEPEND="app-arch/bzip2
- app-arch/gzip
- app-arch/tar
- >=dev-libs/glib-2.0"
-
-RDEPEND="${CDEPEND}
- net-misc/openssh
- sys-apps/coreutils
- sys-apps/findutils
- crypt? ( app-crypt/mcrypt )"
-
-DEPEND="${CDEPEND}
- virtual/pkgconfig"
-
-src_unpack() {
- unpack ${A}
-
- sed -i \
- -e '/hdup:/s|${HDR}.*||' \
- -e 's:GLIB_LIBS *=:LDLIBS =:' \
- -e '/-o hdup/,+1d' \
- "${S}"/src/Makefile.in || die "Makefile fix failed"
-}
-
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-}
+CDEPEND="
+ app-arch/bzip2
+ app-arch/gzip
+ app-arch/tar
+ >=dev-libs/glib-2.0"
+RDEPEND="
+ ${CDEPEND}
+ net-misc/openssh
+ sys-apps/coreutils
+ sys-apps/findutils
+ crypt? ( app-crypt/mcrypt )"
+DEPEND="
+ ${CDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.14-fix-build-system.patch )
src_install() {
- dodir /usr/sbin
- make DESTDIR="${D}" install || die "make install failed"
-
- dohtml doc/FAQ.html
- dodoc ChangeLog Credits README
-
- insinto /usr/share/${PN}/contrib/
- doins contrib/*
+ HTML_DOCS=( doc/FAQ.html )
+ default
+ dodoc Credits
- insinto /usr/share/${PN}/examples/
- doins examples/*
+ insinto /usr/share/${PN}
+ doins -r contrib examples
}
pkg_postinst() {