summaryrefslogtreecommitdiff
path: root/app-backup/hdup/hdup-2.0.14-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/hdup/hdup-2.0.14-r1.ebuild')
-rw-r--r--app-backup/hdup/hdup-2.0.14-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-backup/hdup/hdup-2.0.14-r1.ebuild b/app-backup/hdup/hdup-2.0.14-r1.ebuild
new file mode 100644
index 000000000000..57fb577b246c
--- /dev/null
+++ b/app-backup/hdup/hdup-2.0.14-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Hdup is backup program using tar, find, gzip/bzip2, mcrypt and ssh"
+HOMEPAGE="http://www.miek.nl/projects/hdup2/index.html"
+SRC_URI="http://www.miek.nl/projects/${PN}2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+CDEPEND="
+ app-arch/bzip2
+ app-arch/gzip
+ app-arch/tar
+ >=dev-libs/glib-2.0"
+RDEPEND="
+ ${CDEPEND}
+ virtual/openssh
+ sys-apps/coreutils
+ sys-apps/findutils
+ crypt? ( app-crypt/mcrypt )"
+DEPEND="
+ ${CDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.14-fix-build-system.patch )
+
+src_install() {
+ HTML_DOCS=( doc/FAQ.html )
+ default
+ dodoc Credits
+
+ insinto /usr/share/${PN}
+ doins -r contrib examples
+}
+
+pkg_postinst() {
+ elog "Now edit your /etc/hdup/${PN}.conf to configure your backups."
+ elog "You can also check included examples and contrib, see /usr/share/${PN}/."
+}