summaryrefslogtreecommitdiff
path: root/app-backup/genbackupdata/genbackupdata-1.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/genbackupdata/genbackupdata-1.9.ebuild')
-rw-r--r--app-backup/genbackupdata/genbackupdata-1.9.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-backup/genbackupdata/genbackupdata-1.9.ebuild b/app-backup/genbackupdata/genbackupdata-1.9.ebuild
new file mode 100644
index 000000000000..e6cae7caa61a
--- /dev/null
+++ b/app-backup/genbackupdata/genbackupdata-1.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit distutils-r1
+
+DESCRIPTION="Generate test data for backup software testing."
+HOMEPAGE="http://liw.fi/genbackupdata/"
+#SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/$PN/snapshot/${P}.tar.gz"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/cliapp[${PYTHON_USEDEP}]
+ >=dev-python/ttystatus-0.31[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+ emake genbackupdata.1
+}