summaryrefslogtreecommitdiff
path: root/app-backup/btrbk/btrbk-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/btrbk/btrbk-9999.ebuild')
-rw-r--r--app-backup/btrbk/btrbk-9999.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/app-backup/btrbk/btrbk-9999.ebuild b/app-backup/btrbk/btrbk-9999.ebuild
index f364036c572c..b651574dfd63 100644
--- a/app-backup/btrbk/btrbk-9999.ebuild
+++ b/app-backup/btrbk/btrbk-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -19,18 +19,27 @@ DESCRIPTION="Tool for creating snapshots and remote backups of btrfs subvolumes"
HOMEPAGE="https://digint.ch/btrbk/"
LICENSE="GPL-3+"
SLOT="0"
-IUSE="+pv"
+IUSE="+pv +doc"
-DEPEND=">=app-text/asciidoc-8.6.0
- app-text/xmlto"
+DEPEND="doc? ( >=dev-ruby/asciidoctor-1.5.7 )"
RDEPEND="dev-lang/perl
net-misc/openssh
pv? ( sys-apps/pv )
- >=sys-fs/btrfs-progs-3.18.2"
+ >=sys-fs/btrfs-progs-4.12"
+src_compile() {
+ use doc && emake -C doc COMPRESS=no
+}
src_install() {
- emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" SYSTEMDDIR="$(systemd_get_systemunitdir)" install
+ local targets="install-bin install-etc install-share install-systemd"
+ use doc && targets="${targets} install-man install-doc"
+ emake \
+ COMPRESS=no \
+ DESTDIR="${D}" \
+ DOCDIR="/usr/share/doc/${PF}" \
+ SYSTEMDDIR="$(systemd_get_systemunitdir)" \
+ ${targets}
}
pkg_preinst() {
if has_version "<${CATEGORY}/${PN}-0.26.0" ; then