summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin17934 -> 17943 bytes
-rw-r--r--app-arch/lrzip-next/Manifest2
-rw-r--r--app-arch/lrzip-next/lrzip-next-0.12.6-r1.ebuild67
-rw-r--r--app-arch/lrzip-next/lrzip-next-0.12.6.ebuild50
4 files changed, 68 insertions, 51 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index f3dc61e70022..54fab8613328 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/lrzip-next/Manifest b/app-arch/lrzip-next/Manifest
index d96992944078..f5e6ba518391 100644
--- a/app-arch/lrzip-next/Manifest
+++ b/app-arch/lrzip-next/Manifest
@@ -1,3 +1,3 @@
DIST lrzip-next-0.12.6.tar.gz 600081 BLAKE2B 952b3aefcf424b4626f14caaefc7b160a271330903227207cec249306750dfd24097abfdae159d82dc86e08711f51789ca72bcc66b6d7f4bdd9b892133759dae SHA512 768edaa4059e7a5561a738779cca5e5c46525c0a3f5888fc4e730fe6664f390fa8409060c86076b4b4cc327e317c37d59d557a55db67d97d39da6369788763c8
-EBUILD lrzip-next-0.12.6.ebuild 967 BLAKE2B 02e8b2a6e38c9ffadd7beb8505bb10ee809150c461f3d1b8a32552bb6366b5379105e9302c73dd6019901d5c61e6e987b9c048fef9a8d07c21e8ce169f0fff17 SHA512 d09c763677c6134b0bfd71599c0098c644917fb4c45e1874a2ec17273c56747c4aeabd5f039e91a833e57906a978a8bcc00ed2b928e7119472355592d37abc68
+EBUILD lrzip-next-0.12.6-r1.ebuild 1904 BLAKE2B 93b1816adf9f5fd910a172ce7ddb02cba30674b46c045a830a025882b24f2af581029f9a3eee5453551c023b5bd5fd86f833b46d34719e957fe6832e6b33ac84 SHA512 060c1231786aeba2ecdad2ff77421f144ff905a5470fd820f64bd758495a3c1ca5a5a0f462fc9964881902e4c7b94d00e2b49553945218fea130e843a2ac98fd
MISC metadata.xml 864 BLAKE2B 8305d4f1692bc1daca6e9f5652d6b4cbe0f958013c230f21de1f44fb9a737569c1e5f07070691b5b6b71041e5bd940f1703cc68d42467113a1756f906c2651cf SHA512 2fd25adbf289ddf6b076a0105cb240d8e22f306d0705ba1b98d6abaf92b58b63a5f6413953035b5d837a60f4bc702c64564a4fb195799e0bbd777dd30d6ea365
diff --git a/app-arch/lrzip-next/lrzip-next-0.12.6-r1.ebuild b/app-arch/lrzip-next/lrzip-next-0.12.6-r1.ebuild
new file mode 100644
index 000000000000..e218f7e3e4fe
--- /dev/null
+++ b/app-arch/lrzip-next/lrzip-next-0.12.6-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools
+
+DESCRIPTION="Fork of Con Kolivas' lrzip program for compressing large files"
+HOMEPAGE="https://github.com/pete4abw/lrzip-next"
+SRC_URI="https://github.com/pete4abw/lrzip-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="asm static-libs year2038"
+
+RDEPEND="app-arch/bzip2
+ app-arch/bzip3
+ app-arch/lz4
+ app-arch/zstd
+ dev-libs/libgcrypt
+ dev-libs/libgpg-error
+ dev-libs/lzo
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="amd64? ( dev-lang/nasm )"
+
+src_prepare() {
+ default
+
+ # configure.ac uses a small helper script, ./util/gitdesc.sh, to
+ # see if it's a tarball or git repo copy. If tarball, it extracts
+ # the version information from a local VERSION file and puts it into
+ # configure.ac at the top for major/minor/micro. To avoid the need
+ # for a BDEPEND on dev-vcs/git, we can do this directly.
+ local major=$(awk '/Major: / {printf "%s",$2; exit}' VERSION)
+ local minor=$(awk '/Minor: / {printf "%s",$2; exit}' VERSION)
+ local micro=$(awk '/Micro: / {printf "%s",$2; exit}' VERSION)
+ sed -i -e "s:\[m4_esyscmd_s(\[./util/gitdesc.sh major\])\]:${major}:" configure.ac
+ sed -i -e "s:\[m4_esyscmd_s(\[./util/gitdesc.sh minor\])\]:${minor}:" configure.ac
+ sed -i -e "s:\[m4_esyscmd_s(\[./util/gitdesc.sh micro\])\]:${micro}:" configure.ac
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable static-libs static) \
+ $(use_enable amd64 asm)
+ )
+
+ # This configure switch disappears on a musl system for some
+ # reason. However, this package is currently broken on musl,
+ # but we'll leave this in place while we see if upstream has
+ # any advice.
+ if ! use elibc_musl; then
+ myconf+=( $(use_enable year2038) )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-arch/lrzip-next/lrzip-next-0.12.6.ebuild b/app-arch/lrzip-next/lrzip-next-0.12.6.ebuild
deleted file mode 100644
index 0d3258e4caa8..000000000000
--- a/app-arch/lrzip-next/lrzip-next-0.12.6.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Fork of Con Kolivas' lrzip program for compressing large files"
-HOMEPAGE="https://github.com/pete4abw/lrzip-next"
-SRC_URI="https://github.com/pete4abw/lrzip-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs year2038"
-
-RDEPEND="app-arch/bzip2
- app-arch/bzip3
- app-arch/lz4
- app-arch/zstd
- dev-libs/lzo
- sys-libs/zlib"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-perl/Pod-Parser
- amd64? ( dev-lang/nasm )
- x86? ( dev-lang/nasm )"
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- # ASM optimizations are only available on amd64 and x86
- local asm=no
- if use amd64 || use x86; then
- asm=yes
- fi
-
- econf \
- $(use_enable static-libs static) \
- $(use_enable year2038) \
- --enable-asm=${asm}
-}
-
-src_install() {
- default
- find "${ED}" -name '*.la' -delete || die
-}