summaryrefslogtreecommitdiff
path: root/app-arch/vimball
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/vimball')
-rw-r--r--app-arch/vimball/Manifest6
-rw-r--r--app-arch/vimball/metadata.xml5
-rw-r--r--app-arch/vimball/vimball-0.5.1.ebuild5
-rw-r--r--app-arch/vimball/vimball-9999.ebuild5
4 files changed, 8 insertions, 13 deletions
diff --git a/app-arch/vimball/Manifest b/app-arch/vimball/Manifest
index 51f9cd6e104d..e32ae2eb39e6 100644
--- a/app-arch/vimball/Manifest
+++ b/app-arch/vimball/Manifest
@@ -1,4 +1,4 @@
DIST vimball-0.5.1.tar.gz 5246 BLAKE2B 8ce95bfe8872f69e501b4453e5a6644d8019367173f8675325775dee58e08618b9ec0908bca9df04839bc165b086d8e5195a0753827d6038d8ccd8adbab80c35 SHA512 f89ba7291e3f4146f2ada7934b0ca74524abc639e586da12e19882e9aebe3f14858a6145b830a32dc19b0deb61f652375d8a56dc7847fd0061d14a2d77208549
-EBUILD vimball-0.5.1.ebuild 687 BLAKE2B 8b38f3b9f08aa985cf9f2054145ee7cfc9048558e5515d087ae0847e9d0e2ba2f06ded6a066a8d4816b862fea4c6e22ab45e404e4fdf668c98fa8cbbc0f7e731 SHA512 ec9eb756c2a7a1542db448983360eff3b12a2108f6c128601b2eec748eadae568a0d57152858e932c9b389a8352dc7bff6ff434456c11e4b2b51b13cde1be607
-EBUILD vimball-9999.ebuild 687 BLAKE2B 8b38f3b9f08aa985cf9f2054145ee7cfc9048558e5515d087ae0847e9d0e2ba2f06ded6a066a8d4816b862fea4c6e22ab45e404e4fdf668c98fa8cbbc0f7e731 SHA512 ec9eb756c2a7a1542db448983360eff3b12a2108f6c128601b2eec748eadae568a0d57152858e932c9b389a8352dc7bff6ff434456c11e4b2b51b13cde1be607
-MISC metadata.xml 385 BLAKE2B 5fa1db1263983a5d57031cb72bf9e2b7074faf2134bea6a8cc02d67f9e48ce198c2a8d4a478029d9e3303555c9d248f96e83e6e8071ea7b055f90bb25d38402c SHA512 7086cce11a9a20d93dd24741e060d289c90bbc3c20d5102452d4c987597921b00195badd68d916a64b03faa5dae1fa4adb68654bce5c70c2e1cfa5d8417b33c3
+EBUILD vimball-0.5.1.ebuild 649 BLAKE2B f796f9df8801382e40cb1684d87ffd1e05affb109847d904de71b492ea68fbb491fe9ca769dcf195e1b63c34cd3e9c522c90ed043a5ae9cff081e21c873469df SHA512 b0045ea202e25174555c6db45f1efdb032267759214b62c3029beb65c24966f5ed682a9dd084c27a65fae541a69c4795145b57606a74407a114362b949c08a3e
+EBUILD vimball-9999.ebuild 649 BLAKE2B f796f9df8801382e40cb1684d87ffd1e05affb109847d904de71b492ea68fbb491fe9ca769dcf195e1b63c34cd3e9c522c90ed043a5ae9cff081e21c873469df SHA512 b0045ea202e25174555c6db45f1efdb032267759214b62c3029beb65c24966f5ed682a9dd084c27a65fae541a69c4795145b57606a74407a114362b949c08a3e
+MISC metadata.xml 301 BLAKE2B 07b3d161360551d50927727197e755234ba70034b239c4890aa90cbf863b0e8612be7541c89d503e6d8d80d806485f086e89b071140aba7e63c2f4b78487d3e7 SHA512 5ed23a22a1632cbf42763e8f069f043841ff6eb1c589e7c66b6ab83583da3bf1ec5d820943349fad261a715a9cd61e490242b987556ef9a0bee6fd278cb9e307
diff --git a/app-arch/vimball/metadata.xml b/app-arch/vimball/metadata.xml
index d32fca1cb55b..66b3d21b657e 100644
--- a/app-arch/vimball/metadata.xml
+++ b/app-arch/vimball/metadata.xml
@@ -1,10 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>radhermit@gentoo.org</email>
- <name>Tim Harder</name>
- </maintainer>
+ <!-- maintainer-needed -->
<upstream>
<remote-id type="pypi">vimball</remote-id>
<remote-id type="github">radhermit/vimball</remote-id>
diff --git a/app-arch/vimball/vimball-0.5.1.ebuild b/app-arch/vimball/vimball-0.5.1.ebuild
index 38f71ad8b03d..9bcf7f649ea8 100644
--- a/app-arch/vimball/vimball-0.5.1.ebuild
+++ b/app-arch/vimball/vimball-0.5.1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -21,8 +22,6 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}"
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index 38f71ad8b03d..9bcf7f649ea8 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -21,8 +22,6 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${BDEPEND}"
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {