summaryrefslogtreecommitdiff
path: root/app-arch/vimball/vimball-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/vimball/vimball-9999.ebuild')
-rw-r--r--app-arch/vimball/vimball-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-arch/vimball/vimball-9999.ebuild b/app-arch/vimball/vimball-9999.ebuild
index 82a39960d3ea..280fc206bc04 100644
--- a/app-arch/vimball/vimball-9999.ebuild
+++ b/app-arch/vimball/vimball-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
inherit distutils-r1
if [[ ${PV} == *9999 ]] ; then
@@ -19,10 +19,11 @@ HOMEPAGE="https://github.com/radhermit/vimball"
LICENSE="MIT"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}"
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
esetup.py test