summaryrefslogtreecommitdiff
path: root/app-arch/pxz/pxz-5.0_pre20151029.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/pxz/pxz-5.0_pre20151029.ebuild')
-rw-r--r--app-arch/pxz/pxz-5.0_pre20151029.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/pxz/pxz-5.0_pre20151029.ebuild b/app-arch/pxz/pxz-5.0_pre20151029.ebuild
new file mode 100644
index 000000000000..b530e792a3a6
--- /dev/null
+++ b/app-arch/pxz/pxz-5.0_pre20151029.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Parallel implementation of the XZ compression utility"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+SRC_URI="https://github.com/jnovy/pxz/archive/fcfea93957d96b7661d1439cf4b767ecfd341eed.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+# needs the library from xz-utils
+# needs the libgomp library from gcc at runtime
+RDEPEND="app-arch/xz-utils
+ sys-devel/gcc:*[openmp]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ tc-check-openmp
+ tc-export CC
+ default_src_prepare
+}