summaryrefslogtreecommitdiff
path: root/app-arch/hardlink/hardlink-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/hardlink/hardlink-0.2.0.ebuild')
-rw-r--r--app-arch/hardlink/hardlink-0.2.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/app-arch/hardlink/hardlink-0.2.0.ebuild b/app-arch/hardlink/hardlink-0.2.0.ebuild
deleted file mode 100644
index d2c3f14fffd6..000000000000
--- a/app-arch/hardlink/hardlink-0.2.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit toolchain-funcs
-
-DESCRIPTION="A tool which replaces copies of a file with hardlinks"
-HOMEPAGE="https://jak-linux.org/projects/hardlink/"
-SRC_URI="https://jak-linux.org/projects/${PN}/${PN}_${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE=""
-
-RDEPEND="dev-libs/libpcre
- !>=sys-apps/util-linux-2.34[hardlink]"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS="README ${T}/README.rsync"
-
-src_prepare() {
- sed -i -e '/^CF/s:?=:+=:' -e '/^CF/s:-O2 -g::' Makefile || die
-
- cat <<-EOF > "${T}"/README.rsync
- https://hardlinkpy.googlecode.com/svn/trunk/hardlink.py has regex '^\..*\.\?{6,6}$'
- for excluding rsync temporary files by default.
-
- To accomplish same with this version, you can use following syntax:
- # hardlink -x '^\..*\.\?{6,6}$'
-
- This was discussed at https://bugs.gentoo.org/416613
- EOF
-}
-
-src_compile() {
- tc-export CC
- emake
-}