summaryrefslogtreecommitdiff
path: root/app-arch/dpkg/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/dpkg/files')
-rw-r--r--app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch11
-rw-r--r--app-arch/dpkg/files/dpkg-1.17.1-flags.patch11
-rw-r--r--app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch10
-rw-r--r--app-arch/dpkg/files/dpkg-1.18.12-flags.patch11
-rw-r--r--app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch28
5 files changed, 71 insertions, 0 deletions
diff --git a/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch b/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch
new file mode 100644
index 000000000000..f956ca590ce7
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch
@@ -0,0 +1,11 @@
+--- a/scripts/Dpkg/Compression.pm
++++ b/scripts/Dpkg/Compression.pm
+@@ -52,7 +52,7 @@
+ my $COMP = {
+ gzip => {
+ file_ext => 'gz',
+- comp_prog => [ 'gzip', '--no-name', '--rsyncable' ],
++ comp_prog => [ 'gzip', '--no-name' ],
+ decomp_prog => [ 'gunzip' ],
+ default_level => 9,
+ },
diff --git a/app-arch/dpkg/files/dpkg-1.17.1-flags.patch b/app-arch/dpkg/files/dpkg-1.17.1-flags.patch
new file mode 100644
index 000000000000..9517714fa41b
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.17.1-flags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -104,8 +104,6 @@
+ # Checks for the build machinery.
+ AC_DEFINE(LIBDPKG_VOLATILE_API, 1, [Acknowledge the volatility of the API.])
+ DPKG_COMPILER_WARNINGS
+-DPKG_COMPILER_OPTIMISATIONS
+-DPKG_LINKER_OPTIMISATIONS
+ DPKG_ARCHITECTURE
+
+ AC_CONFIG_FILES([ Makefile
diff --git a/app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch b/app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch
new file mode 100644
index 000000000000..e9716758d41b
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch
@@ -0,0 +1,10 @@
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -238,7 +238,6 @@
+ t/Dpkg_Source_Package.t \
+ t/Dpkg_Dist_Files.t \
+ t/dpkg_source.t \
+- t/dpkg_buildpackage.t \
+ t/merge_changelogs.t \
+ t/mk.t \
+ $(nil)
diff --git a/app-arch/dpkg/files/dpkg-1.18.12-flags.patch b/app-arch/dpkg/files/dpkg-1.18.12-flags.patch
new file mode 100644
index 000000000000..bee7dd729941
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.18.12-flags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,8 +182,6 @@
+ # Checks for the build machinery.
+ AC_DEFINE([LIBDPKG_VOLATILE_API], [1], [Acknowledge the volatility of the API.])
+ DPKG_COMPILER_WARNINGS
+-DPKG_COMPILER_OPTIMIZATIONS
+-DPKG_LINKER_OPTIMIZATIONS
+ DPKG_ARCHITECTURE
+ AC_DEFINE([PACKAGE_RELEASE], [PACKAGE_VERSION " (" ARCHITECTURE ")"],
+ [Define the project release information, version and architecture])
diff --git a/app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch b/app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch
new file mode 100644
index 000000000000..69802da67092
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch
@@ -0,0 +1,28 @@
+--- a/scripts/Dpkg/Compression.pm
++++ b/scripts/Dpkg/Compression.pm
+@@ -81,20 +81,12 @@
+ };
+
+ #
+-# XXX: The gzip package in Debian at some point acquired a Debian-specific
+-# --rsyncable option via a vendor patch. Which is not present in most of the
+-# major distributions, dpkg downstream systems, nor gzip upstream, who have
+-# stated they will most probably not accept it because people should be using
+-# pigz instead.
++# If gzip supports --rsyncable (version >=1.7 or the Debian patched variant),
++# we use it. Sadly a non-compliant gzip will not complain about the argument
++# when it does not understand it, so we can only print out the usage and infer
++# --rsyncable support from that.
+ #
+-# This option should have never been accepted in dpkg, ever. But removing it
+-# now would probably cause demands for tarring and feathering. In addition
+-# we cannot use the Dpkg::Vendor logic because that would cause circular
+-# module dependencies. The whole affair is pretty disgusting really.
+-#
+-# Check the perl Config to discern Debian and hopefully derivatives too.
+-#
+-if ($Config{cf_by} eq 'Debian Project') {
++if (system("gzip --help 2>&1 | grep -q -- --rsyncable") == 0) {
+ push @{$COMP->{gzip}->{comp_prog}}, '--rsyncable';
+ }
+