summaryrefslogtreecommitdiff
path: root/app-arch/afio
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/afio')
-rw-r--r--app-arch/afio/Manifest4
-rw-r--r--app-arch/afio/afio-2.5.1-r1.ebuild32
-rw-r--r--app-arch/afio/files/afio-2.5.1-fix-build-system.patch22
-rw-r--r--app-arch/afio/metadata.xml15
4 files changed, 73 insertions, 0 deletions
diff --git a/app-arch/afio/Manifest b/app-arch/afio/Manifest
new file mode 100644
index 000000000000..e7070037ae8c
--- /dev/null
+++ b/app-arch/afio/Manifest
@@ -0,0 +1,4 @@
+AUX afio-2.5.1-fix-build-system.patch 725 BLAKE2B 3ec8c1068d60db73727fabb02eae50005c1aef8db39df977add2ab312d627fbc16b107b1f007fad9be5b97d1afe02ec0fd38c97c80a804464f1e3985868a3f67 SHA512 ccf6af4e1591d9c8e519dcb9016c49c0a8601f2a03949270b205560bb13e90bdbd50079c4e0abcc3e6290a809ffb24455c00ee5cd70c0168b31b1c01b9bfc093
+DIST afio-2.5.1.tgz 191765 BLAKE2B 48a590c1180942444eb8fc17701563ee822cad9d0ae423e12996e7b3dff16ab7ba13d8041b78fb6415d1a422d14be8ba3443910ae1a57290dca801334ced7ffe SHA512 afa4e01cc9e7da5bff7c96d2da9a41c296e7b89c50484f58a8b011173a99a144a9e77d3ee8136622e490287b99a7ae76c6eba901a2186b5a3a6bab164a37c864
+EBUILD afio-2.5.1-r1.ebuild 687 BLAKE2B 8c2a97cccf64764bffcb2bc2f48f427f31d66b8a866629ec0e37f96196799bdf818c4afbd631a3d7caed2025d6a98b5897598b0f1afed133113e11d1453d4208 SHA512 f7a87a25cb38074faee92f6a6952b7060d73dd2311c7792f459b45419a995490a8686666525576c0a53300a003d51142fc50295ef105841369c2657cdd07c77e
+MISC metadata.xml 591 BLAKE2B 1f4dfca240f8986aba12ac0ee887fc49ccb50248c300d318e09807aa2552f6dc642f0f8a629fd34f1156b9e8407f7a429245893f999afc87db90cb9860329fc7 SHA512 ecde4bb37f668f30eedbb5b07a648fa23183d64593595948e6caf575fa78f8c666a406ed33b4d590190203920e1db7368dfc99b95948a7ab7896d12490f50760
diff --git a/app-arch/afio/afio-2.5.1-r1.ebuild b/app-arch/afio/afio-2.5.1-r1.ebuild
new file mode 100644
index 000000000000..3f2b5791d5fe
--- /dev/null
+++ b/app-arch/afio/afio-2.5.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Afio creates cpio-format archives."
+HOMEPAGE="http://members.chello.nl/k.holtman/afio.html https://github.com/kholtman/afio"
+SRC_URI="http://members.chello.nl/k.holtman/${P}.tgz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~hppa ppc sparc x86"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.5.1-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+
+ local i
+ for i in {1..4}; do
+ docinto "script${i}"
+ dodoc -r "script${i}"/.
+ done
+}
diff --git a/app-arch/afio/files/afio-2.5.1-fix-build-system.patch b/app-arch/afio/files/afio-2.5.1-fix-build-system.patch
new file mode 100644
index 000000000000..5f3e8355c1a2
--- /dev/null
+++ b/app-arch/afio/files/afio-2.5.1-fix-build-system.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -71,15 +71,12 @@
+ MW=
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+
+-CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
+-
+-CC=gcc
+-
+-CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
+-LDFLAGS =
++CC ?= gcc
++CFLAGS += -Wall -Wstrict-prototypes
++CPPFLAGS += ${LARGEFILEFLAGS} ${2} ${3} ${6} ${8} ${c} ${d} ${e2} ${f} ${g}
+
+ afio : afio.o compfile.o exten.o match.o $M
+- ${CC} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
++ $(CC) $(CFLAGS) $(LDFLAGS) $^ -o $@
+
+ clean:
+ rm -f *.o afio
diff --git a/app-arch/afio/metadata.xml b/app-arch/afio/metadata.xml
new file mode 100644
index 000000000000..1d91069b9e13
--- /dev/null
+++ b/app-arch/afio/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>
+ Afio makes cpio-format archives. It deals somewhat gracefully
+ with input data corruption, supports multi-volume archives during interactive
+ operation, and can make compressed archives that are much safer than compressed
+ tar or cpio archives. Afio is best used as an 'archive engine' in a backup
+ script.
+ </longdescription>
+ <upstream>
+ <remote-id type="freshmeat">afio</remote-id>
+ </upstream>
+</pkgmetadata>