summaryrefslogtreecommitdiff
path: root/app-arch/afio/afio-2.5.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/afio/afio-2.5.2.ebuild')
-rw-r--r--app-arch/afio/afio-2.5.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-arch/afio/afio-2.5.2.ebuild b/app-arch/afio/afio-2.5.2.ebuild
new file mode 100644
index 000000000000..d646d4a7b503
--- /dev/null
+++ b/app-arch/afio/afio-2.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="CPIO-Archiver & backup program with fault tolerant compression"
+HOMEPAGE="https://github.com/kholtman/afio"
+SRC_URI="https://github.com/kholtman/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.2-fix-build-system.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+
+ local i
+ for i in {1..4}; do
+ docinto "script${i}"
+ dodoc -r "script${i}"/.
+ done
+}