summaryrefslogtreecommitdiff
path: root/app-alternatives/sh/sh-0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-alternatives/sh/sh-0.ebuild')
-rw-r--r--app-alternatives/sh/sh-0.ebuild37
1 files changed, 11 insertions, 26 deletions
diff --git a/app-alternatives/sh/sh-0.ebuild b/app-alternatives/sh/sh-0.ebuild
index 5da158c80cab..882b960924a4 100644
--- a/app-alternatives/sh/sh-0.ebuild
+++ b/app-alternatives/sh/sh-0.ebuild
@@ -3,40 +3,25 @@
EAPI=8
-DESCRIPTION="/bin/sh (POSIX shell) symlink"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
-SRC_URI=""
-S=${WORKDIR}
+ALTERNATIVES=(
+ bash:app-shells/bash
+ dash:app-shells/dash
+ ksh:app-shells/ksh
+ "lksh:app-shells/mksh[lksh]"
+ mksh:app-shells/mksh
+)
+
+inherit app-alternatives
-LICENSE="CC0-1.0"
-SLOT="0"
+DESCRIPTION="/bin/sh (POSIX shell) symlink"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="+bash dash ksh lksh mksh"
-REQUIRED_USE="^^ ( bash dash ksh lksh mksh )"
RDEPEND="
- bash? ( app-shells/bash )
- dash? ( app-shells/dash )
- ksh? ( app-shells/ksh )
- lksh? ( app-shells/mksh[lksh] )
- mksh? ( app-shells/mksh )
!!app-eselect/eselect-sh
"
src_install() {
- if use bash; then
- dosym bash /bin/sh
- elif use dash; then
- dosym dash /bin/sh
- elif use ksh; then
- dosym ksh /bin/sh
- elif use lksh; then
- dosym lksh /bin/sh
- elif use mksh; then
- dosym mksh /bin/sh
- else
- die "Invalid USE flag combination (broken REQUIRED_USE?)"
- fi
+ dosym "$(get_alternative)" /bin/sh || die
}
pkg_postrm() {