summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/augeas/augeas-1.11.0-r1.ebuild50
-rw-r--r--app-admin/augeas/augeas-1.11.0.ebuild47
-rw-r--r--app-admin/lib_users/lib_users-0.14-r2.ebuild44
-rw-r--r--app-admin/restart-services/restart-services-0.15.2.ebuild63
-rw-r--r--app-admin/restart-services/restart-services-0.16.0.ebuild63
-rw-r--r--app-admin/restart-services/restart-services-0.16.1.ebuild63
6 files changed, 0 insertions, 330 deletions
diff --git a/app-admin/augeas/augeas-1.11.0-r1.ebuild b/app-admin/augeas/augeas-1.11.0-r1.ebuild
deleted file mode 100644
index 2ae229699ae7..000000000000
--- a/app-admin/augeas/augeas-1.11.0-r1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="A library for changing configuration files"
-HOMEPAGE="http://augeas.net/"
-SRC_URI="http://download.augeas.net/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ~ppc64 sparc x86"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libxml2
- sys-libs/readline:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=app-doc/NaturalDocs-1.40
- test? ( dev-lang/ruby )"
-
-PATCHES=(
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # selinux needs to implemented
- econf \
- --without-selinux \
- $(use_enable static-libs static)
-}
-
-src_compile() {
- addpredict /usr/share/NaturalDocs/Config/Languages.txt
- addpredict /usr/share/NaturalDocs/Config/Topics.txt
- default
-}
-
-src_install() {
- default
- use static-libs || find "${D}" -name '*.la' -delete || die
-}
diff --git a/app-admin/augeas/augeas-1.11.0.ebuild b/app-admin/augeas/augeas-1.11.0.ebuild
deleted file mode 100644
index 0f2936e58b91..000000000000
--- a/app-admin/augeas/augeas-1.11.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="A library for changing configuration files"
-HOMEPAGE="http://augeas.net/"
-SRC_URI="http://download.augeas.net/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~ppc64 sparc x86"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/libxml2
- sys-libs/readline:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- >=app-doc/NaturalDocs-1.40
- test? ( dev-lang/ruby )"
-
-PATCHES=(
-)
-
-src_prepare() {
- if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
- addwrite /usr/share/NaturalDocs/Config/Languages.txt
- fi
- if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
- addwrite /usr/share/NaturalDocs/Config/Topics.txt
- fi
- default
-}
-
-src_configure() {
- # Needs to implemented
- local myeconfargs="--without-selinux
- $(use_enable !static-libs shared)
- $(use_enable static-libs static)"
- eautoreconf
- econf ${myeconfargs}
- default
-}
diff --git a/app-admin/lib_users/lib_users-0.14-r2.ebuild b/app-admin/lib_users/lib_users-0.14-r2.ebuild
deleted file mode 100644
index 3d25d62d3176..000000000000
--- a/app-admin/lib_users/lib_users-0.14-r2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit python-r1
-
-DESCRIPTION="Check for mapped libs and open files that are marked as deleted"
-HOMEPAGE="https://github.com/klausman/lib_users"
-SRC_URI="https://github.com/klausman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-RDEPEND="${PYTHON_DEPS}"
-
-src_test() {
- python_foreach_impl nosetests --verbosity=2
-}
-
-my_install() {
- python_newscript lib_users.py lib_users
- python_newscript fd_users.py fd_users
- # lib_users_util/ contains a test script we don't want, so do things by hand
- python_moduleinto lib_users_util
- python_domodule lib_users_util/common.py
- python_domodule lib_users_util/__init__.py
-}
-
-src_install() {
- python_foreach_impl my_install
- dodoc README.md TODO
-}
diff --git a/app-admin/restart-services/restart-services-0.15.2.ebuild b/app-admin/restart-services/restart-services-0.15.2.ebuild
deleted file mode 100644
index 7aa078cf4b21..000000000000
--- a/app-admin/restart-services/restart-services-0.15.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Tool to manage OpenRC services that need to be restarted"
-HOMEPAGE="https://dev.gentoo.org/~mschiff/restart-services/"
-SRC_URI="https://dev.gentoo.org/~mschiff/src/${PN}/${P}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- app-admin/lib_users
- sys-apps/openrc
- app-portage/portage-utils
-"
-
-src_install() {
- dosbin restart-services
- doman restart-services.1
- keepdir /etc/restart-services.d
- insinto /etc
- doins restart-services.conf
- dodoc README CHANGES
-
- sed -i 's/^#include/include/' "${D}"/etc/restart-services.conf
- cat>"${D}"/etc/restart-services.d/00-local.conf<<-EOF
- # You may put your local changes here or in any other *.conf file
- # in this directory so you can leave /etc/restart-services.conf as is.
- # Example:
- # *extend* SV_ALWAYS to match 'myservice'
- # SV_ALWAYS+=( myservice )
- EOF
-}
-
-pkg_postinst() {
- local MAJOR MINOR
- # migrate config data for versions < 0.13.2
- if [[ $REPLACING_VERSIONS ]]; then
- MAJOR=${REPLACING_VERSIONS%%.*}
- MINOR=${REPLACING_VERSIONS%.*}
- MINOR=${MINOR#*.}
-
- if [[ $MAJOR -eq 0 && $MINOR -lt 14 ]]; then
- einfo "Checking for old config"
- if [[ -f /etc/restart_services.conf ]]; then
- ewarn "Old config file found: /etc/restart_services.conf"
- ewarn "It will be ignored so please migrate settings to a file in"
- ewarn "/etc/restart-services.d/ and/or remove /etc/restart_services.conf"
- fi
- if [[ -d /etc/restart_services.d ]]; then
- ewarn "Old config directory found: /etc/restart_services.d"
- ewarn "It will be ignored so please migrate files to /etc/restart-services.d"
- ewarn "and/or remove /etc/restart_services.d"
- fi
- einfo "done"
- fi
- fi
-}
diff --git a/app-admin/restart-services/restart-services-0.16.0.ebuild b/app-admin/restart-services/restart-services-0.16.0.ebuild
deleted file mode 100644
index 874ac8f35520..000000000000
--- a/app-admin/restart-services/restart-services-0.16.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Tool to manage OpenRC services that need to be restarted"
-HOMEPAGE="https://dev.gentoo.org/~mschiff/restart-services/"
-SRC_URI="https://dev.gentoo.org/~mschiff/src/${PN}/${P}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- app-admin/lib_users
- sys-apps/openrc
- app-portage/portage-utils
-"
-
-src_install() {
- dosbin restart-services
- doman restart-services.1
- keepdir /etc/restart-services.d
- insinto /etc
- doins restart-services.conf
- dodoc README CHANGES
-
- sed -i 's/^#include/include/' "${D}"/etc/restart-services.conf
- cat>"${D}"/etc/restart-services.d/00-local.conf<<-EOF
- # You may put your local changes here or in any other *.conf file
- # in this directory so you can leave /etc/restart-services.conf as is.
- # Example:
- # *extend* SV_ALWAYS to match 'myservice'
- # SV_ALWAYS+=( myservice )
- EOF
-}
-
-pkg_postinst() {
- local MAJOR MINOR
- # migrate config data for versions < 0.13.2
- if [[ $REPLACING_VERSIONS ]]; then
- MAJOR=${REPLACING_VERSIONS%%.*}
- MINOR=${REPLACING_VERSIONS%.*}
- MINOR=${MINOR#*.}
-
- if [[ $MAJOR -eq 0 && $MINOR -lt 14 ]]; then
- einfo "Checking for old config"
- if [[ -f /etc/restart_services.conf ]]; then
- ewarn "Old config file found: /etc/restart_services.conf"
- ewarn "It will be ignored so please migrate settings to a file in"
- ewarn "/etc/restart-services.d/ and/or remove /etc/restart_services.conf"
- fi
- if [[ -d /etc/restart_services.d ]]; then
- ewarn "Old config directory found: /etc/restart_services.d"
- ewarn "It will be ignored so please migrate files to /etc/restart-services.d"
- ewarn "and/or remove /etc/restart_services.d"
- fi
- einfo "done"
- fi
- fi
-}
diff --git a/app-admin/restart-services/restart-services-0.16.1.ebuild b/app-admin/restart-services/restart-services-0.16.1.ebuild
deleted file mode 100644
index 874ac8f35520..000000000000
--- a/app-admin/restart-services/restart-services-0.16.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Tool to manage OpenRC services that need to be restarted"
-HOMEPAGE="https://dev.gentoo.org/~mschiff/restart-services/"
-SRC_URI="https://dev.gentoo.org/~mschiff/src/${PN}/${P}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
- app-admin/lib_users
- sys-apps/openrc
- app-portage/portage-utils
-"
-
-src_install() {
- dosbin restart-services
- doman restart-services.1
- keepdir /etc/restart-services.d
- insinto /etc
- doins restart-services.conf
- dodoc README CHANGES
-
- sed -i 's/^#include/include/' "${D}"/etc/restart-services.conf
- cat>"${D}"/etc/restart-services.d/00-local.conf<<-EOF
- # You may put your local changes here or in any other *.conf file
- # in this directory so you can leave /etc/restart-services.conf as is.
- # Example:
- # *extend* SV_ALWAYS to match 'myservice'
- # SV_ALWAYS+=( myservice )
- EOF
-}
-
-pkg_postinst() {
- local MAJOR MINOR
- # migrate config data for versions < 0.13.2
- if [[ $REPLACING_VERSIONS ]]; then
- MAJOR=${REPLACING_VERSIONS%%.*}
- MINOR=${REPLACING_VERSIONS%.*}
- MINOR=${MINOR#*.}
-
- if [[ $MAJOR -eq 0 && $MINOR -lt 14 ]]; then
- einfo "Checking for old config"
- if [[ -f /etc/restart_services.conf ]]; then
- ewarn "Old config file found: /etc/restart_services.conf"
- ewarn "It will be ignored so please migrate settings to a file in"
- ewarn "/etc/restart-services.d/ and/or remove /etc/restart_services.conf"
- fi
- if [[ -d /etc/restart_services.d ]]; then
- ewarn "Old config directory found: /etc/restart_services.d"
- ewarn "It will be ignored so please migrate files to /etc/restart-services.d"
- ewarn "and/or remove /etc/restart_services.d"
- fi
- einfo "done"
- fi
- fi
-}