summaryrefslogtreecommitdiff
path: root/app-admin
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/Manifest.gzbin32013 -> 32012 bytes
-rw-r--r--app-admin/bitwarden-desktop-bin/Manifest2
-rw-r--r--app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.4.1.ebuild87
-rw-r--r--app-admin/webapp-config/Manifest4
-rw-r--r--app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch11
-rw-r--r--app-admin/webapp-config/webapp-config-1.55-r4.ebuild91
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild8
7 files changed, 200 insertions, 3 deletions
diff --git a/app-admin/Manifest.gz b/app-admin/Manifest.gz
index dd36eb35ab65..552bb294e970 100644
--- a/app-admin/Manifest.gz
+++ b/app-admin/Manifest.gz
Binary files differ
diff --git a/app-admin/bitwarden-desktop-bin/Manifest b/app-admin/bitwarden-desktop-bin/Manifest
index 7faab0af62cb..72792caf44d4 100644
--- a/app-admin/bitwarden-desktop-bin/Manifest
+++ b/app-admin/bitwarden-desktop-bin/Manifest
@@ -1,5 +1,7 @@
DIST Bitwarden-2024.2.0-amd64.deb 79917282 BLAKE2B 2066dc71bed9cddbcedccfd9129e3e81ac9f8a71217d2c651fb8a067b3e318574e26104b447a7ccd6734efded64ef3620cf4a7e36f0a577ed98f5468839540cb SHA512 c9394914fd6c82096fc5336e73b539e250727c6917af97961df0bd7de241f955b9eb87da154f32972c73ea1ce59bf0d79660658277185c89e099360ec4c3ea26
DIST Bitwarden-2024.3.0-amd64.deb 80463348 BLAKE2B 668fd4c18507b349e5892e7511b4898764a33d9da0a837379c7856caa054782fbf6a3337b03a779a8c8111d2458f560b31c32856850ff931694a8f18d889bdc9 SHA512 9297367e82e76870b7f12becfca6ec3bc0ce8f6515f4e17e9830d4df599891c839a8f5990c97b684528c8a4ad1c24ddd3bc99c1552620aee84b81c1cbf115771
+DIST Bitwarden-2024.4.1-amd64.deb 80470012 BLAKE2B 64b451c3fbbac303782c68a366c66c32c49d0ecb52bcbc085451157216cc99fa888941e8c911c14f6a68aa6bb0413463b4296f108386e7b5b3ca8925c6dcc871 SHA512 e6edcd84f44062ccfa4152baf7dab230915d006f7f31de0ffcbe1acb62525777c7d653a7cb7c51509fb9ebcf5ba4219df97e5128853813a54aadbfd92ff2c819
EBUILD bitwarden-desktop-bin-2024.2.0.ebuild 1689 BLAKE2B 80d621cf295463043cbf79341d07dbb18f8e659bd866901ad6c208495dfc6e84904aa96a104ebb710183a6355412c66918a59e9065fa3edbc4e148950ce109b6 SHA512 378dd06d8917e0f61dc9d55ac9bb02ebd8951783dcfce56d0b502fa766208451e6abf2e111d6bd83de3ff8ec7b4e8b506337aecbd3e8a41753a65d39e4692180
EBUILD bitwarden-desktop-bin-2024.3.0.ebuild 1689 BLAKE2B 80d621cf295463043cbf79341d07dbb18f8e659bd866901ad6c208495dfc6e84904aa96a104ebb710183a6355412c66918a59e9065fa3edbc4e148950ce109b6 SHA512 378dd06d8917e0f61dc9d55ac9bb02ebd8951783dcfce56d0b502fa766208451e6abf2e111d6bd83de3ff8ec7b4e8b506337aecbd3e8a41753a65d39e4692180
+EBUILD bitwarden-desktop-bin-2024.4.1.ebuild 1689 BLAKE2B 80d621cf295463043cbf79341d07dbb18f8e659bd866901ad6c208495dfc6e84904aa96a104ebb710183a6355412c66918a59e9065fa3edbc4e148950ce109b6 SHA512 378dd06d8917e0f61dc9d55ac9bb02ebd8951783dcfce56d0b502fa766208451e6abf2e111d6bd83de3ff8ec7b4e8b506337aecbd3e8a41753a65d39e4692180
MISC metadata.xml 323 BLAKE2B 3f1affe8fb7b242a0ea072faaebcccd37bf005ee68c7519857701c37fe6a11b0dffe1692af141b54218367ee8c8361cb0e6608621453d424d52b061b569563d1 SHA512 95ab28dcb844ac6d2ba4573699e86a4c303aa46b4c2eddf1273ecf37a3bbb751b9a478b535fbdcbc12424bc4f826b4b0781cfb8079e5563ed41f12ce68b35908
diff --git a/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.4.1.ebuild b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.4.1.ebuild
new file mode 100644
index 000000000000..a98f129ada65
--- /dev/null
+++ b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-2024.4.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop unpacker xdg-utils
+
+MY_PN="Bitwarden"
+
+DESCRIPTION="Bitwarden password manager desktop client"
+HOMEPAGE="https://bitwarden.com/"
+SRC_URI="https://github.com/bitwarden/clients/releases/download/desktop-v${PV}/Bitwarden-${PV}-amd64.deb"
+S="${WORKDIR}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/nspr
+ dev-libs/nss
+ dev-libs/wayland
+ media-libs/alsa-lib
+ media-libs/mesa
+ net-print/cups
+ sys-apps/dbus
+ sys-apps/util-linux
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libxshmfence
+ x11-libs/libXtst
+ x11-libs/pango
+"
+IDEPEND="
+ dev-util/desktop-file-utils
+ dev-util/gtk-update-icon-cache
+"
+
+QA_PREBUILT="
+ opt/Bitwarden/*.so*
+ opt/Bitwarden/bitwarden
+ opt/Bitwarden/chrome-sandbox
+ opt/Bitwarden/chrome_crashpad_handler
+"
+
+src_install() {
+ insinto /opt
+ doins -r opt/${MY_PN}
+ fperms 755 /opt/Bitwarden/bitwarden
+ fperms 4755 /opt/Bitwarden/chrome-sandbox
+
+ domenu usr/share/applications/bitwarden.desktop
+
+ local x
+ for x in 16 32 64 128 256 512; do
+ doicon -s ${x} usr/share/icons/hicolor/${x}*/*
+ done
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index 4067d9623eb7..c4c3e53d643e 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,4 +1,6 @@
+AUX webapp-config-1.55-py3.122-invalid-escape-sequence.patch 334 BLAKE2B 49579635819c92cbb47b3ed7be47d1e5dd1ad3469de1a89fe5d6ffa26e5e6290d5c090419227c9e572b348cb9297ebd7bfe33bee7e4557d55b348d68731f1aaf SHA512 0163b3cf649b54747cf8fef6b2c91017ab59c92d50c8b96fc5231491e104db20c1de968fa8fc70774f64b91d58c798467d1d0a48093cd7269cbf385aaccd49f5
DIST webapp-config-1.55.tar.bz2 72583 BLAKE2B be958dc991f0e1f6835d9c29350b7d97e3f23d52971f6013165ce59a8f4b32ac6262c9719956d1bcdbe60797f07d77910b44a749ae545c4dc15f765525144709 SHA512 44294b276fd036908438cd984ebf70433639caa18d8330bab348433b4f39ea2c42c57fa8de4f0a6198f7875429a3ef9ebe61321c288d910f9be8b3414865f438
EBUILD webapp-config-1.55-r3.ebuild 2454 BLAKE2B 8e4807d5a9daba21868277eb49f877ff9f72f6a435eaba51c32530382a1d347d6c8b2adf600a2b39f825512c7e03cd7a60600f9947b75108869fb9d696dd2671 SHA512 277d1ab115d57eef90c8af161e61be7ec424d0a4578edfadae2d9f06e7f372744d47f863cc5abc5138afca5d7d4d964e6735d6fa54e5b13e386eccd964924908
-EBUILD webapp-config-9999.ebuild 2461 BLAKE2B 190826599765147db3d87c3af1b753946baebc1c6d2ede348341188e4586fda6662a3f11cb37e5ed1a5d2f93fe995fd265c7da07ea3f295b4c4502520f872b63 SHA512 a6a166671465821d6fb6ccbd27e0e70e2efccb61a7117b166e063e9afa91f2c1140e380b02fd88fa1cdf8611525c0679b9d6d0ea61b41b44e3733bda43fc5b88
+EBUILD webapp-config-1.55-r4.ebuild 2546 BLAKE2B 22c3c0fbce94c3844327e26c1892b7ca8a68dc35ba35d2f9c7a9d80489570edeeaeb37137be327279dca9e1564a4e7f94a14b5e5e3b8b66329f3d8872bb39409 SHA512 b631235e96df3f31d09c0643982105ba3016f0073b614bc298b5216f8e23735cdd149ec60082b5ef7c5e6fece10d6b9e6abfe7291022fb2ea1dd33bb876d5b90
+EBUILD webapp-config-9999.ebuild 2546 BLAKE2B 22c3c0fbce94c3844327e26c1892b7ca8a68dc35ba35d2f9c7a9d80489570edeeaeb37137be327279dca9e1564a4e7f94a14b5e5e3b8b66329f3d8872bb39409 SHA512 b631235e96df3f31d09c0643982105ba3016f0073b614bc298b5216f8e23735cdd149ec60082b5ef7c5e6fece10d6b9e6abfe7291022fb2ea1dd33bb876d5b90
MISC metadata.xml 448 BLAKE2B 14bff33f87640b065d72b7bd98742c602e1cd30be80cde6bbc5bd923cb8529f55e4296e83e630e55a9c8342da063dc3762f515bccd2614fc50d68770260fd727 SHA512 20db75371335720225afe0111925fe6ba3979448987a27459786a4490b862073ac23374ba29c218e523ea465fb811c7686d5a36e073a35a2a2b2c4521b6961f2
diff --git a/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch b/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
new file mode 100644
index 000000000000..cb1ba1a8593e
--- /dev/null
+++ b/app-admin/webapp-config/files/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
@@ -0,0 +1,11 @@
+--- a/WebappConfig/protect.py
++++ b/WebappConfig/protect.py
+@@ -78,7 +78,7 @@
+
+ numbers = []
+ prefix = self.protect_prefix
+- rep = re.compile(prefix.replace('.','\.') + '(\d{4})_')
++ rep = re.compile(prefix.replace('.',r'\.') + r'(\d{4})_')
+
+ for i in entries:
+ rem = rep.match(i)
diff --git a/app-admin/webapp-config/webapp-config-1.55-r4.ebuild b/app-admin/webapp-config/webapp-config-1.55-r4.ebuild
new file mode 100644
index 000000000000..cc2e8028b578
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.55-r4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 prefix
+
+if [[ ${PV} = 9999* ]]
+then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="https://sourceforge.net/projects/webapp-config/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+portage"
+
+DEPEND="app-text/xmlto
+ sys-apps/gentoo-functions"
+RDEPEND="
+ portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
+)
+
+python_prepare_all() {
+ # make the source from svn mirror the one in the tarball
+ if [[ ${PV} == 9999* ]]; then
+ mkdir ../webapp-config || die "Cannot create temp directory."
+ cp -r * ../webapp-config || die "Cannot copy all into the temp directory."
+ mv ../webapp-config . || die "Cannot move temp directory to its final position."
+
+ # Installation fails if version is 1.55-git
+ sed -e 's/-git//' \
+ -i webapp-config/WebappConfig/version.py \
+ -i WebappConfig/version.py || die "Cannot fix version."
+ fi
+
+ distutils-r1_python_prepare_all
+ eprefixify WebappConfig/eprefix.py config/webapp-config
+}
+
+python_compile_all() {
+ emake -C doc/
+}
+
+python_test() {
+ PYTHONPATH="." "${EPYTHON}" WebappConfig/tests/external.py -v ||
+ die "Testing failed with ${EPYTHON}"
+}
+
+python_install() {
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils-r1_python_install --install-scripts="${EPREFIX}/usr/sbin"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # distutils-r1 installs the scripts in /usr/bin in PEP517 mode
+ mv "${ED}"/usr/bin "${ED}"/usr/sbin || die "Cannot rename scripts directory to /usr/sbin"
+
+ insinto /etc/vhosts
+ doins config/webapp-config
+
+ keepdir /usr/share/webapps
+ keepdir /var/db/webapps
+
+ dodoc AUTHORS
+ doman doc/*.[58]
+}
+
+pkg_postinst() {
+ elog "Now that you have upgraded webapp-config, you **must** update your"
+ elog "config files in /etc/vhosts/webapp-config before you emerge any"
+ elog "packages that use webapp-config."
+}
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 76caefb23e6d..cc2e8028b578 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 prefix
@@ -29,6 +29,10 @@ DEPEND="app-text/xmlto
RDEPEND="
portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
+)
+
python_prepare_all() {
# make the source from svn mirror the one in the tarball
if [[ ${PV} == 9999* ]]; then