summaryrefslogtreecommitdiff
path: root/app-admin/webapp-config/webapp-config-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config/webapp-config-9999.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 76caefb23e6d..cc2e8028b578 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 prefix
@@ -29,6 +29,10 @@ DEPEND="app-text/xmlto
RDEPEND="
portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
+PATCHES=(
+ "${FILESDIR}"/webapp-config-1.55-py3.122-invalid-escape-sequence.patch
+)
+
python_prepare_all() {
# make the source from svn mirror the one in the tarball
if [[ ${PV} == 9999* ]]; then