summaryrefslogtreecommitdiff
path: root/app-admin/ttyplot
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ttyplot')
-rw-r--r--app-admin/ttyplot/Manifest3
-rw-r--r--app-admin/ttyplot/metadata.xml11
-rw-r--r--app-admin/ttyplot/ttyplot-1.5.1.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/app-admin/ttyplot/Manifest b/app-admin/ttyplot/Manifest
new file mode 100644
index 000000000000..c8d0459a135b
--- /dev/null
+++ b/app-admin/ttyplot/Manifest
@@ -0,0 +1,3 @@
+DIST ttyplot-1.5.1.gh.tar.gz 43629 BLAKE2B 98c46c27587a6ed98f7ed146b402dcbb6f5835f2f34780ccd706dc56b674dec3792dfb8bf84c8d260c040952ef0431341df09c16d032f32d4621c5f3971857d7 SHA512 3eb255375366bc3a773364388dc709f4f5b9961e1c99404dfd192503b20a8eb064f5089811b8c894a8214f84d24e14d040adb0b34712915311eb28972586bf0b
+EBUILD ttyplot-1.5.1.ebuild 543 BLAKE2B 7f9974816705530096921b04c9025de905671b948132b84e41f2779a4f81f449f1472a968352f8a818a172e14dcee98f0d618c237fb7b72b3efe724d5848ca1b SHA512 5b21e285e7ea461d5f83356533c57d565911af06faa4bbcf625fae75d6c096db4442670f88f6058e7a0f0fee6dcd95426b881ea5ca1e666c294dc0e823abf2f6
+MISC metadata.xml 329 BLAKE2B bd5447e3674a73231ebd7a5bb2a617d00fba46b3cc681954c29f8784001f86e0a3085cf614b5c59b26f0a47300dc01a4f8047f05d57ed898d43c0014ddf33f65 SHA512 a150258d92fc957ab9f70dac4b083afc417493c666de1aa4cba92fbf7b79b6c793790cb97a6c44a9c60c1668e9f28008467451efc0f5ad4dd0b27f6302b238f1
diff --git a/app-admin/ttyplot/metadata.xml b/app-admin/ttyplot/metadata.xml
new file mode 100644
index 000000000000..ae2c63465dde
--- /dev/null
+++ b/app-admin/ttyplot/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sping@gentoo.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tenox7/ttyplot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/ttyplot/ttyplot-1.5.1.ebuild b/app-admin/ttyplot/ttyplot-1.5.1.ebuild
new file mode 100644
index 000000000000..31b1533c83eb
--- /dev/null
+++ b/app-admin/ttyplot/ttyplot-1.5.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Realtime plotting utility with data input from stdin"
+HOMEPAGE="https://github.com/tenox7/ttyplot"
+SRC_URI="https://github.com/tenox7/ttyplot/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ local args=(
+ PREFIX=/usr
+ MANPREFIX=/usr/share/man
+ DESTDIR="${D}"
+ )
+ emake "${args[@]}" install
+}