summaryrefslogtreecommitdiff
path: root/app-admin/terraform/terraform-0.11.11.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/terraform/terraform-0.11.11.ebuild')
-rw-r--r--app-admin/terraform/terraform-0.11.11.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/terraform/terraform-0.11.11.ebuild b/app-admin/terraform/terraform-0.11.11.ebuild
new file mode 100644
index 000000000000..15c8b080b179
--- /dev/null
+++ b/app-admin/terraform/terraform-0.11.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-lang/go-1.11.0"
+
+src_compile() {
+ cd "src/${EGO_PN}" || die
+ GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
+ -v -work -o "${S}/${PN}" ./ || die
+}
+
+src_install() {
+ dobin terraform
+}