summaryrefslogtreecommitdiff
path: root/app-admin/sysrqd/files/sysrqd-14-fix-build-system.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sysrqd/files/sysrqd-14-fix-build-system.patch')
-rw-r--r--app-admin/sysrqd/files/sysrqd-14-fix-build-system.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-admin/sysrqd/files/sysrqd-14-fix-build-system.patch b/app-admin/sysrqd/files/sysrqd-14-fix-build-system.patch
new file mode 100644
index 000000000000..2668c3c0c491
--- /dev/null
+++ b/app-admin/sysrqd/files/sysrqd-14-fix-build-system.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -5,15 +5,15 @@
+ -Wundef -Wshadow -Wcast-align -Wwrite-strings -Wsign-compare \
+ -Wunused -Winit-self -Wpointer-arith -Wredundant-decls \
+ -Wmissing-prototypes -Wmissing-format-attribute -Wmissing-noreturn \
+- -std=gnu99 -pipe -DSYSRQD_VERSION="\"$(VERSION)\"" -O3
++ -std=gnu99
++CPPFLAGS += -DSYSRQD_VERSION="\"$(VERSION)\""
+
+ SBINDIR=$(DESTDIR)/usr/sbin
+ #MANDIR=$(DESTDIR)/usr/share/man/man1
+ INSTALL = install
+ #MAN=sysrqd.1
+
+-$(BIN): $(O)
+- $(CC) $(LDFLAGS) -o $(BIN) $(O)
++all: $(BIN)
+
+ install: $(BIN)
+ $(INSTALL) -d -m 755 $(SBINDIR)