summaryrefslogtreecommitdiff
path: root/app-admin/supervisor
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/Manifest2
-rw-r--r--app-admin/supervisor/supervisor-4.2.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-admin/supervisor/Manifest b/app-admin/supervisor/Manifest
index c43b3745ad01..48ace87e9304 100644
--- a/app-admin/supervisor/Manifest
+++ b/app-admin/supervisor/Manifest
@@ -4,6 +4,8 @@ AUX supervisord.conf 2525 BLAKE2B d36d6ef6b952a99ccfd61976c21eb54922555db4802288
AUX supervisord.service 404 BLAKE2B 87c99a2b388befb04f1d8e3442a5c0b6d802837047c45da2bb7017631bf4af4b858bc4d7964f1d64937e331728884bc21e62e9d01b11cca46aaea389372c6bad SHA512 0fe777d1f0bf70dc9b49132102ac90083261321850f80e9e323459c894c55f722ab8470eba3ba7bb35a9d69ad411a3247546066d6cba5801c9b289350ea4bed5
DIST supervisor-4.0.4.tar.gz 437708 BLAKE2B 211726da07ce31c00da0d6edba57942d78ee5d2757927b22afe569364c29aaf55375d4895b381f06071bc6b6c39a926ca2073e8fcb8e0ea9673a89aafd08b346 SHA512 22a38f759b0584310f5e16acbfc7b0c4cc59f3206fbfaf6295bd40a826d50ad02c8b0093821362c5038dd987a6599879d82dcefe948a2eda702b89e9f92e471e
DIST supervisor-4.1.0.tar.gz 459020 BLAKE2B 0c4bdc2c89f54c08ad536b43852941f1aadb0173013e0f73337302f500b779023bfa0fcf8cc3ace4968cfc724998a08ea5a63680e290051d13c7cd8ac788dd24 SHA512 1ae343293707ebf33d0a0c0bda2c6cc78278e12737940a79e51b2365e7a20b07d9f5e50134ed2abbf8e7af1ebd8f1746002a159cde1cfc35e83fda0a77dae9c5
+DIST supervisor-4.2.0.tar.gz 456056 BLAKE2B 51b66cfc34505b937c47c9b510d81bcc777b9372fdeb2e08fc25153d2718cd2682258b812630160954587ceb992e1a528cdd5bf0d270139f7ffac9463ac2f015 SHA512 626d806f4b03be7cbff795afd1bdb3ff5ca5ecf44f035909ea1aa9360da9fa3047b2fe05543190bf1442f01dcdd403be19fcd907519bf7e26615900bc4bf9d0f
EBUILD supervisor-4.0.4.ebuild 1889 BLAKE2B 742a09c3881070eb8bb8356521a8064689341055dd23b449bfe150449c4fba4d0e60800c329fc3b2c1ad2f84f34ddac293d698183999b3ccd7814108a60d0916 SHA512 dd02e46bf2d19adc95da5ff836851e900a636d8f9b41317a5fbe3d39485391d8a597d4af1522884a5c6cedf8986f0e8338f46a7e160c6c66d702df26550b1849
EBUILD supervisor-4.1.0.ebuild 1479 BLAKE2B c6ce3863be2f873514d1c170c9140bb5288c65729c83a81f8620a64780db2f84a659ddd6d5978cdea9f6df683026cb444ca1f920be8cdc234558a8d206e8b8fe SHA512 bcb297829bec3c8bfb8b2b41813a4e2f30ca8b92400e1cd286a4c69ab051bc52045198a1bbfdae824c20f58e6c82d6b5e86bc9b2ce556a68069b50c5aabaaca8
+EBUILD supervisor-4.2.0.ebuild 1719 BLAKE2B 0641569200d065d7964dab1ef0f2e720701b7679229ca0abb7fb5576dd93f8cc5f047a51a10788687b4db7b9242a48050a6ca39ab80fc7ce671ca12a8f17cc0c SHA512 16c9a0f6ec942ca56aceeff8cd3a86c7d74e865d0c0dea1b2237f827754f8231b830409662f99ec4c16d01126bb6b158263ce0ba7a9f03660285d71e3966fa4d
MISC metadata.xml 623 BLAKE2B dc7acae3a83fce87bdaf98f65ba4ac2434e0344faeb8ad302dcba5be3a59f2b6ffa9d85338ad432100d5e1017e40bbeb606724a214097e14bcc7082eb331986a SHA512 f05e62f68c51fe2bab054d03b3a902682eaaa133de08ac558a92736868dcc8049d1f27828e3ecae8f5f64b038bb8a322e58c90401e6fe01d215941e1507076e8
diff --git a/app-admin/supervisor/supervisor-4.2.0.ebuild b/app-admin/supervisor/supervisor-4.2.0.ebuild
new file mode 100644
index 000000000000..607c68383023
--- /dev/null
+++ b/app-admin/supervisor/supervisor-4.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+# xml.etree.ElementTree module required.
+PYTHON_REQ_USE="xml(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 systemd
+
+MY_PV="${PV/_beta/b}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ https://pypi.org/project/supervisor/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="repoze ZPL BSD HPND GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="acct-group/supervisor"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Skip one test that currently fails
+ # https://github.com/Supervisor/supervisor/issues/1346
+ sed -i 's/test_prepare_socket/_&/' \
+ supervisor/tests/test_socket_manager.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ newinitd "${FILESDIR}/init.d-r2" supervisord
+ newconfd "${FILESDIR}/conf.d-r1" supervisord
+ dodoc supervisor/skel/sample.conf
+ keepdir /etc/supervisord.d
+ insinto /etc
+ doins "${FILESDIR}/supervisord.conf"
+ keepdir /var/log/supervisor
+ systemd_dounit "${FILESDIR}/supervisord.service"
+}
+
+pkg_preinst() {
+ fowners :supervisor /var/log/supervisor
+ fperms 750 /var/log/supervisor
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ # This is a new installation
+ elog "You may install your configuration files in ${EROOT}/etc/supervisord.d"
+ elog "For config examples, see ${EROOT}/usr/share/doc/${PF}/sample.conf.bz2"
+ elog ""
+ elog "By default, only members of the supervisor group can run supervisorctl."
+ fi
+}