summaryrefslogtreecommitdiff
path: root/app-admin/sudo/sudo-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/sudo/sudo-9999.ebuild')
-rw-r--r--app-admin/sudo/sudo-9999.ebuild42
1 files changed, 19 insertions, 23 deletions
diff --git a/app-admin/sudo/sudo-9999.ebuild b/app-admin/sudo/sudo-9999.ebuild
index fc4f44f8e4fc..cecc68448ea9 100644
--- a/app-admin/sudo/sudo-9999.ebuild
+++ b/app-admin/sudo/sudo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,7 @@ else
SRC_URI="https://www.sudo.ws/sudo/dist/${uri_prefix}${MY_P}.tar.gz
ftp://ftp.sudo.ws/pub/sudo/${uri_prefix}${MY_P}.tar.gz"
if [[ ${PV} != *_beta* ]] && [[ ${PV} != *_rc* ]] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~sparc-solaris"
fi
fi
@@ -30,10 +30,11 @@ fi
# 3-clause BSD license
LICENSE="ISC BSD"
SLOT="0"
-IUSE="gcrypt ldap libressl nls offensive pam sasl +secure-path selinux +sendmail skey sssd system-digest"
+IUSE="gcrypt ldap libressl nls offensive pam sasl +secure-path selinux +sendmail skey ssl sssd"
DEPEND="
sys-libs/zlib:=
+ gcrypt? ( dev-libs/libgcrypt:= )
ldap? (
>=net-nds/openldap-2.1.30-r1
sasl? (
@@ -44,14 +45,11 @@ DEPEND="
pam? ( sys-libs/pam )
sasl? ( dev-libs/cyrus-sasl )
skey? ( >=sys-auth/skey-1.1.5-r1 )
- sssd? ( sys-auth/sssd[sudo] )
- system-digest? (
- gcrypt? ( dev-libs/libgcrypt:= )
- !gcrypt? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
)
+ sssd? ( sys-auth/sssd[sudo] )
"
RDEPEND="
${DEPEND}
@@ -137,36 +135,34 @@ src_configure() {
# until `make` time, so we have to use a full path here rather than
# basing off other values.
myeconfargs=(
- --enable-zlib=system
+ # requires some python eclass
+ --disable-python
--enable-tmpfiles.d="${EPREFIX}"/usr/lib/tmpfiles.d
+ --enable-zlib=system
--with-editor="${EPREFIX}"/usr/libexec/editor
--with-env-editor
--with-plugindir="${EPREFIX}"/usr/$(get_libdir)/sudo
--with-rundir="${EPREFIX}"/run/sudo
- $(use_with secure-path secure-path "${SECURE_PATH}")
--with-vardir="${EPREFIX}"/var/db/sudo
--without-linux-audit
--without-opie
$(use_enable gcrypt)
$(use_enable nls)
$(use_enable sasl)
+ $(use_enable ssl openssl)
+ $(use_with ldap)
+ $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo)
$(use_with offensive insults)
$(use_with offensive all-insults)
- $(use_with ldap ldap_conf_file /etc/ldap.conf.sudo)
- $(use_with ldap)
$(use_with pam)
- $(use_with skey)
- $(use_with sssd)
+ $(use_with pam pam-login)
+ $(use_with secure-path secure-path "${SECURE_PATH}")
$(use_with selinux)
$(use_with sendmail)
+ $(use_with skey)
+ $(use_with sssd)
)
- if use system-digest && ! use gcrypt; then
- myeconfargs+=("--enable-openssl")
- else
- myeconfargs+=("--disable-openssl")
- fi
-
econf "${myeconfargs[@]}"
}
@@ -209,7 +205,7 @@ src_install() {
# Don't install into /run as that is a tmpfs most of the time
# (bug #504854)
- rm -rf "${ED}"/run
+ rm -rf "${ED}"/run || die
find "${ED}" -type f -name "*.la" -delete || die #697812
}