summaryrefslogtreecommitdiff
path: root/app-admin/selint/selint-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/selint/selint-1.1.0.ebuild')
-rw-r--r--app-admin/selint/selint-1.1.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/selint/selint-1.1.0.ebuild b/app-admin/selint/selint-1.1.0.ebuild
new file mode 100644
index 000000000000..592cb7fbdf8f
--- /dev/null
+++ b/app-admin/selint/selint-1.1.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Policy Analysis Tools for SELinux"
+HOMEPAGE="https://github.com/TresysTechnology/selint/wiki"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/TresysTechnology/selint.git"
+else
+ SRC_URI="https://github.com/TresysTechnology/selint/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/confuse:=
+ dev-libs/uthash"
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )"
+
+src_prepare() {
+ [[ ${PV} == 9999 ]] && eautoreconf
+
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with test check)
+}