summaryrefslogtreecommitdiff
path: root/app-admin/rex/rex-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/rex/rex-9999.ebuild')
-rw-r--r--app-admin/rex/rex-9999.ebuild28
1 files changed, 22 insertions, 6 deletions
diff --git a/app-admin/rex/rex-9999.ebuild b/app-admin/rex/rex-9999.ebuild
index d832e4f2b87a..6942c13d2e55 100644
--- a/app-admin/rex/rex-9999.ebuild
+++ b/app-admin/rex/rex-9999.ebuild
@@ -62,11 +62,10 @@ RDEPEND="
dev-perl/IO-String
dev-perl/IO-Tty
dev-perl/JSON-MaybeXS
- dev-perl/List-MoreUtils
virtual/perl-MIME-Base64
dev-perl/Net-OpenSSH
dev-perl/Net-SFTP-Foreign
- virtual/perl-Scalar-List-Utils
+ >=virtual/perl-Scalar-List-Utils-1.450.0
dev-perl/Parallel-ForkManager
dev-perl/Sort-Naturally
dev-perl/String-Escape
@@ -82,7 +81,7 @@ RDEPEND="
dev-perl/YAML
virtual/perl-version
"
-
+# NB: would add test? !minimal? Test-mysqld, but I can't get that to work
BDEPEND="
${RDEPEND}
>=virtual/perl-CPAN-Meta-Requirements-2.120.620
@@ -90,6 +89,9 @@ BDEPEND="
>=dev-perl/File-ShareDir-Install-0.60.0
virtual/perl-Module-Metadata
test? (
+ !minimal? (
+ dev-perl/File-LibMagic
+ )
virtual/perl-File-Temp
dev-perl/Test-Deep
dev-perl/Test-Output
@@ -121,8 +123,9 @@ dzil_src_prep() {
# so that the final [d]elete deletes the next line too. Can be expanded for each
# line, ie: {N;N;N;d} deletes 3 lines after the match as well as the match.
sed -e '/^\[Test::Kwalitee\]/d' \
- -e '/^\[Test::Perl::Critic\]/d' \
-e '/^\[PodSyntaxTests\]/d' \
+ -e '/^Perl::Critic::Freenode =/d' \
+ -e '/^Perl::Critic::TooMuchCode =/d' \
-e '/^Test::Kwalitee =/d' \
-e '/^Test::PerlTidy =/d' \
-e '/^Test::Pod =/d' \
@@ -130,10 +133,16 @@ dzil_src_prep() {
-e '/^\[OptionalFeature/,/^$/d' \
-e '/^\[Test::MinimumVersion\]/{N;d}' \
-i dist.ini || die "Can't patch dist.ini"
+
+ # Removals/additons have to be tracked by git or dzil build fails
+ # Spurious warning during src_prepare
+ git rm -f xt/author/critic-progressive.t || die "Can't rm author/critic-progressive.t"
+ # Spurious warning during src_prepare
+ git rm -f xt/author/perltidy.t || die "Can't rm author/perltidy.t"
}
dzil_env_setup() {
# NextRelease noise :(
- mkdir -p ~/.dzil/
+ mkdir -p ~/.dzil/ || die "mkdir -p ~/.dzil/ failed"
local user="$(whoami)"
local host="$(hostname)"
printf '[%%User]\nname = %s\nemail = %s' "${user}" "${user}@${host}" >> ~/.dzil/config.ini
@@ -146,7 +155,7 @@ dzil_to_distdir() {
cd "${dzil_root}" || die "Can't enter git workdir '${dzil_root}'";
- dzil_src_prep
+ S="${dzil_root}" dzil_src_prep
dzil_env_setup
dzil_version="$(dzil version)" || die "Error invoking 'dzil version'"
@@ -190,6 +199,13 @@ src_prepare() {
dzil_to_distdir "${EGIT_CHECKOUT_DIR}" "${S}"
fi
cd "${S}" || die "Can't enter build dir"
+
+ # If you DIY installed Test::mysqld, but didn't patch
+ # it to handle the fact on Gentoo, mysql_install_db is NOT in PATH
+ # tests fail. So this test is patched out if mysql_install_db is not in PATH
+ if perl_has_module "Test::mysqld" && ! type -P mysql_install_db >/dev/null; then
+ perl_rm_files "t/db.t"
+ fi
perl-module_src_prepare
}