summaryrefslogtreecommitdiff
path: root/app-admin/python-updater
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/python-updater')
-rw-r--r--app-admin/python-updater/Manifest6
-rw-r--r--app-admin/python-updater/metadata.xml8
-rw-r--r--app-admin/python-updater/python-updater-0.14.ebuild37
-rw-r--r--app-admin/python-updater/python-updater-9999.ebuild37
4 files changed, 88 insertions, 0 deletions
diff --git a/app-admin/python-updater/Manifest b/app-admin/python-updater/Manifest
new file mode 100644
index 000000000000..96b56f087190
--- /dev/null
+++ b/app-admin/python-updater/Manifest
@@ -0,0 +1,6 @@
+DIST python-updater-0.14.tar.bz2 10354 SHA256 78b8a8680ef2a64baf2e1a3624694967ea119109f9c171106b93e02661f3ba4a SHA512 6d5589326a1dc1cb83c42a0d1cdadce4e33ee25a1699e93475d5167666f06fda900822fa3f5657c473999860a36cfb6f6dd1312b66695e47ad3035404e26b9db WHIRLPOOL 6d839525fabdf19f8fc729bc341cb13bfdec2a5f96eff9524ea8af018987c86d284aa7a52a6c1f32aac34403f0fef47a9a7e6963b91282529bc30997c6d2666b
+EBUILD python-updater-0.14.ebuild 1064 SHA256 4a3f8c031420c711ef563762c112a5993c1bf4ea15d238e46199c5d1017ed754 SHA512 fc62c55e1e3d099be2000ae59c1a1f315b6b0e1709a77717f557cfb09e70de9a94656d373820023b605c418be99d92211e5cda72638835d8a50bc94d09112c85 WHIRLPOOL 408b72b77e7cc3405452b53cd48a9d97508be9b579f4516ec38c06aed83f5a97400b61485d9b5bb44dcaf683fdf6f0b4b91e1db990faf4537d689ecdfef79944
+EBUILD python-updater-9999.ebuild 926 SHA256 84f97d37e95fe67260d4bd6cfbf4e2687e1fef300b76a91be705b2e7f3217470 SHA512 aa89856534e7ce4993a44b7ef4bc0f41d3e478b8cb6df919c505556ed7778255ed7610648312ef264faf979a8803ea58adb545f22f8f9d2cfcdde8849725d83e WHIRLPOOL a991c011e6ec61a48e7db035d15e232e450be2791673c481e53aa50a3f91a13b30ebd2cf56a3705aa29587810bde5fba2b474aaf4f300eca1ea94660180d3cb0
+MISC ChangeLog 5057 SHA256 a0d529204a8bd3bc6087983dd733a298a42635495fb5b7a83fd298c080a78d7f SHA512 7a7e2824dfcc42fac42c8d93ef24e2d42a2df1e94bfaf18d44113d2a25975ce16f885d7f72ad641f7f52fb01710a8b0c5d2a8b84b90f175798bcf1e0a59f4134 WHIRLPOOL 6878308417ae36ff01c9dd3851e8bd4826b3ae3e9b571cc11aa4050f341a6c0e0cc8d3c0f7b93572a56ff4973fdb35d477c81766c5258e51eeba6beddc8f45f8
+MISC ChangeLog-2015 13308 SHA256 0f01ea2ccccf360f53458908d18ab104669427bac6c132abb4990a718f1b32cf SHA512 40a06e66699d1df0a16a3e70c6a22e97f8e21583065de6e11e2fd654859dff2b28489c0f4354565499a0445f81ca8510cf1ce6b5bbccb5ee333985e84f87d809 WHIRLPOOL 41514a89d4708d708403f22e04c4c3fb5c1c538afdef1b5a848c50fe81385d12706631adfcfb41ade2649bb31b0013a3478650123bc6f0cdf6fb11e3a49e2f41
+MISC metadata.xml 236 SHA256 4709fa7f17a11d5eae6dd884b488d3c6eb8f85e9b63fe3684b4f234d3b9b14a9 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3 WHIRLPOOL d73790bb41c2cefb5e2f7b163fc95a79b9674d9808ca34cef58fbc8c5a765023a0be285508a2e7f5f70eadc5725cf8d63553d599e4b367f52fac3374de347abb
diff --git a/app-admin/python-updater/metadata.xml b/app-admin/python-updater/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/app-admin/python-updater/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-admin/python-updater/python-updater-0.14.ebuild b/app-admin/python-updater/python-updater-0.14.ebuild
new file mode 100644
index 000000000000..73a56953cebd
--- /dev/null
+++ b/app-admin/python-updater/python-updater-0.14.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="Script used to reinstall Python packages after changing active Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/python-updater.git"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND="
+ sys-apps/gentoo-functions
+ sys-apps/help2man
+ "
+fi
+RDEPEND="
+ sys-apps/gentoo-functions
+ || ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 sys-apps/pkgcore )
+"
+
+src_compile() {
+ [[ ${PV} == 9999 ]] && emake python-updater
+ default
+}
diff --git a/app-admin/python-updater/python-updater-9999.ebuild b/app-admin/python-updater/python-updater-9999.ebuild
new file mode 100644
index 000000000000..8e2df7dfc60b
--- /dev/null
+++ b/app-admin/python-updater/python-updater-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="Script used to reinstall Python packages after changing active Python versions"
+HOMEPAGE="https://www.gentoo.org/proj/en/Python/"
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="git://anongit.gentoo.org/proj/python-updater.git"
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND="
+ sys-apps/gentoo-functions
+ sys-apps/help2man
+ "
+fi
+RDEPEND="
+ sys-apps/gentoo-functions
+ || ( >=sys-apps/portage-2.1.6 >=sys-apps/paludis-0.56.0 sys-apps/pkgcore )
+"
+
+src_compile() {
+ [[ ${PV} == 9999 ]] && emake python-updater
+ default
+}