summaryrefslogtreecommitdiff
path: root/app-admin/pwgen/pwgen-2.08.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwgen/pwgen-2.08.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.08.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-admin/pwgen/pwgen-2.08.ebuild b/app-admin/pwgen/pwgen-2.08.ebuild
new file mode 100644
index 000000000000..e7712ee76083
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.08.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="https://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="livecd"
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/etc/pwgen
+}
+
+src_install() {
+ default
+
+ use livecd && newinitd "${FILESDIR}"/pwgen.rc pwgen
+}