summaryrefslogtreecommitdiff
path: root/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild')
-rw-r--r--app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild b/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..0e60b33f530b
--- /dev/null
+++ b/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="An improved version of cli-crypt (encrypts data sent to it from the cli)"
+HOMEPAGE="http://xjack.org/pwcrypt/"
+SRC_URI="http://xjack.org/pwcrypt/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DOCS=( CREDITS README )
+
+src_prepare() {
+ default
+ sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile.in || die
+ sed -i \
+ -e "/^LDFLAGS/s/= /= @LDFLAGS@ /" \
+ -e "/-install/s/ -s//" \
+ src/Makefile.in || die
+
+ tc-export CC
+}