summaryrefslogtreecommitdiff
path: root/app-admin/puppet/puppet-7.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/puppet/puppet-7.5.0.ebuild')
-rw-r--r--app-admin/puppet/puppet-7.5.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/app-admin/puppet/puppet-7.5.0.ebuild b/app-admin/puppet/puppet-7.5.0.ebuild
index 5b564665270e..65ed31b7def3 100644
--- a/app-admin/puppet/puppet-7.5.0.ebuild
+++ b/app-admin/puppet/puppet-7.5.0.ebuild
@@ -4,14 +4,11 @@
EAPI="6"
USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
RUBY_FAKEGEM_TASK_DOC="doc:all"
-
RUBY_FAKEGEM_EXTRAINSTALL="locales"
-inherit eutils ruby-fakegem eapi7-ver
+inherit epatch ruby-fakegem
DESCRIPTION="A system automation and configuration management software."
HOMEPAGE="https://puppet.com/"
@@ -19,7 +16,7 @@ SRC_URI="http://downloads.puppetlabs.com/puppet/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86"
IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite vim-syntax"
RESTRICT="test"
@@ -109,12 +106,14 @@ all_ruby_install() {
fowners -R :puppet /var/lib/puppet
if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
+ insinto /etc/openldap/schema
+ doins ext/ldap/puppet.schema
fi
# ext and examples files
for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}"
+ docinto "$(dirname ${f})"
+ dodoc "${f}"
done
}