summaryrefslogtreecommitdiff
path: root/app-admin/longrun/longrun-0.9-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/longrun/longrun-0.9-r5.ebuild')
-rw-r--r--app-admin/longrun/longrun-0.9-r5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-admin/longrun/longrun-0.9-r5.ebuild b/app-admin/longrun/longrun-0.9-r5.ebuild
new file mode 100644
index 000000000000..1cbda722a3ef
--- /dev/null
+++ b/app-admin/longrun/longrun-0.9-r5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="A utility to control Transmeta's Crusoe and Efficeon processors"
+HOMEPAGE="http://freshmeat.net/projects/longrun/"
+
+DEBIAN_PATCH_VERSION="22"
+DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff"
+SRC_URI="
+ https://www.kernel.org/pub/linux/utils/cpu/crusoe/${P}.tar.bz2
+ mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-ppc ~x86"
+
+BDEPEND="sys-apps/groff"
+
+DOCS=( MAKEDEV-cpuid-msr )
+
+CONFIG_CHECK="~X86_MSR ~X86_CPUID"
+ERROR_X86_MSR="
+Longrun needs a MSR device to function. Please select
+MSR under Processor type and features. It can be build
+directly into the kernel or as a module."
+ERROR_X86_CPUID="
+Longrun needs a CPUID device to function. Please select
+CPUID under Processor type and features. It can be
+build directly into the kernel or as a module."
+
+PATCHES=(
+ "${WORKDIR}"/${DEBIAN_PATCH}
+ "${FILESDIR}"/${PV}-makefile_cflags.patch
+ "${FILESDIR}"/${PV}-replace-loff_t.patch
+)
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+pkg_postinst() {
+ if linux_config_exists; then
+ if linux_chkconfig_module X86_MSR; then
+ elog "You have compiled MSR as a module."
+ elog "You need to load it before using Longrun."
+ elog "The module is called msr."
+ elog
+ fi
+
+ if linux_chkconfig_module X86_CPUID; then
+ elog "You have compiled CPUID as a module."
+ elog "You need to load it before using Longrun."
+ elog "The module is called cpuid."
+ fi
+ else
+ elog "You have no kernel configuration available."
+ elog "Longrun needs both CPUID and MSR capabilites,"
+ elog "in the kernel you intend to run it under."
+ fi
+}