summaryrefslogtreecommitdiff
path: root/app-admin/lnav/lnav-0.8.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/lnav/lnav-0.8.2.ebuild')
-rw-r--r--app-admin/lnav/lnav-0.8.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/lnav/lnav-0.8.2.ebuild b/app-admin/lnav/lnav-0.8.2.ebuild
new file mode 100644
index 000000000000..c7ce22bb4de3
--- /dev/null
+++ b/app-admin/lnav/lnav-0.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A curses-based tool for viewing and analyzing log files"
+HOMEPAGE="http://lnav.org"
+SRC_URI="https://github.com/tstack/lnav/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="unicode"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-db/sqlite:3
+ dev-libs/libpcre[cxx]
+ >=net-misc/curl-7.23.0
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS NEWS README )
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_with unicode ncursesw)
+}