summaryrefslogtreecommitdiff
path: root/app-admin/keepassxc/keepassxc-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/keepassxc/keepassxc-9999.ebuild')
-rw-r--r--app-admin/keepassxc/keepassxc-9999.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-admin/keepassxc/keepassxc-9999.ebuild b/app-admin/keepassxc/keepassxc-9999.ebuild
index 186c07c60416..4b24b9ee85b7 100644
--- a/app-admin/keepassxc/keepassxc-9999.ebuild
+++ b/app-admin/keepassxc/keepassxc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,10 +15,12 @@ if [[ "${PV}" != *9999 ]] ; then
S="${WORKDIR}/${P/_/-}"
else
SRC_URI="https://github.com/keepassxreboot/${PN}/releases/download/${PV}/${P}-src.tar.xz"
+
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
fi
else
inherit git-r3
+
EGIT_REPO_URI="https://github.com/keepassxreboot/${PN}"
[[ "${PV}" != 9999 ]] && EGIT_BRANCH="master"
fi
@@ -42,24 +44,28 @@ RDEPEND="
dev-qt/qtwidgets:5
media-gfx/qrencode:=
sys-libs/readline:0=
- sys-libs/zlib:=
- X? ( dev-qt/qtx11extras:5 )
+ sys-libs/zlib:=[minizip]
+ X? (
+ dev-qt/qtx11extras:5
+ )
autotype? (
x11-libs/libX11
x11-libs/libXtst
)
- keeshare? ( sys-libs/zlib:=[minizip] )
yubikey? (
dev-libs/libusb:1
sys-apps/pcsc-lite
)
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
dev-qt/qttest:5
"
BDEPEND="
dev-qt/linguist-tools:5
- doc? ( dev-ruby/asciidoctor )
+ doc? (
+ dev-ruby/asciidoctor
+ )
"
src_prepare() {
@@ -74,7 +80,7 @@ src_configure() {
# https://github.com/keepassxreboot/keepassxc/issues/5801
filter-lto
- local mycmakeargs=(
+ local -a mycmakeargs=(
# Gentoo users enable ccache via e.g. FEATURES=ccache or
# other means. We don't want the build system to enable it for us.
-DWITH_CCACHE=OFF