summaryrefslogtreecommitdiff
path: root/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ide-smart/ide-smart-1.4-r1.ebuild')
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r1.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
index cac5d77934f3..5ffb6e04cbb2 100644
--- a/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
+++ b/app-admin/ide-smart/ide-smart-1.4-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="A tool to read SMART information from harddiscs"
@@ -12,12 +14,22 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
IUSE=""
-src_compile() {
- $(tc-getCC) ${CFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c || die "compile"
+PATCHES=( "${FILESDIR}"/${PN}-1.4-fix-build-system.patch )
+
+src_prepare() {
+ default
+
+ # yes, the tarball includes pre-compiled
+ # object files and binaries
+ rm ${PN}{,.o} || die
+}
+
+src_configure() {
+ tc-export CC
}
src_install() {
- dobin ide-smart || die
+ dobin ide-smart
doman ide-smart.8
- dodoc README
+ einstalldocs
}