summaryrefslogtreecommitdiff
path: root/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch')
-rw-r--r--app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
new file mode 100644
index 000000000000..ad523e36b3f9
--- /dev/null
+++ b/app-admin/ide-smart/files/ide-smart-1.4-fix-build-system.patch
@@ -0,0 +1,17 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,13 +2,10 @@
+
+ #CC = gcc
+ PROF = -g0 -O2
+-CFLAGS = $(PROF) -Wall
+-LDFLAGS = $(PROF)
++CFLAGS += -Wall
+ TARGET = ide-smart
+ OBJECTS = ide-smart.o
+
+-ide-smart: $(OBJECTS)
+- $(CC) $(LDFLAGS) -o $(TARGET) $(OBJECTS)
+
+ all: ide-smart
+