summaryrefslogtreecommitdiff
path: root/app-admin/graylog2
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/graylog2')
-rw-r--r--app-admin/graylog2/Manifest2
-rw-r--r--app-admin/graylog2/graylog2-2.5.1.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/graylog2/Manifest b/app-admin/graylog2/Manifest
index 77b17ae7e6cd..7a95817208b2 100644
--- a/app-admin/graylog2/Manifest
+++ b/app-admin/graylog2/Manifest
@@ -1,5 +1,7 @@
AUX confd-r2 542 BLAKE2B 83a8b2a3bf1fc60a2a9475d823efe39febb961d0aaee12b7b18f1d2752427e401fe2f68c83f777fba1d2f585540f4d9b422befcc959aa082a26eeef2be093b2b SHA512 fde38b6813f40633db5d5cbcb3d93fd17e8705d6f2c5805fdc900858fe2b0cf0c0c219345dc741cc2573b1f80b42fdf5714e71fa31938329355556503492bbb8
AUX initd-r2 872 BLAKE2B 500a428a0f479dc79b1d8b7d6a1acfafe9a205a65adfacd10aa6f5e89c105c30e095e69799acd8739d9ed2b7dee0ed6d053497a74495a986b6d9b24122c29a75 SHA512 43632bd345bb3772018ce1fe32a97c85a1ad812dca2ae229dccb65302e686597dad4b62ecbc0cc5358c34761f354d51de2c9fe81bd3db71af5fdc0a6cbc0e95e
DIST graylog-2.4.6.tgz 122985232 BLAKE2B 3a409a08f27c3abf1eadca57c4e8c9afc334655e050c0db9bad9d16e03acab6d92bfced708486ad8383987842d9b0a5ddc54e28d29fc426761fcb0ab8c65844c SHA512 e1941f4740f43c5b92b5faa7cde06fb15294acfed5f0f56cb21a7ceffb8616382b68b67d049a2982c68833d706e57b77f365665f12193d053a2ac0996801bcbe
+DIST graylog-2.5.1.tgz 123878927 BLAKE2B d168579be4d20e3a8081d608247e7101fc5d99ddd2b5f063f94d7e91d4095c6bd016a4bc1be0f0e08b5043b771070312286404ece5eacc51e4a8730dfc13dab1 SHA512 44e2ca00e47a34708cea94b74fdc0f56f3a381f161d25633bdf7685fbcd989937163508f8b47b0869c7daacec6c8bd2c874f9381e196ffb3194eb6e3f96b3ce9
EBUILD graylog2-2.4.6.ebuild 2289 BLAKE2B c1b21ab668e1c0877b3cfcadf63538de1a3eaf9a85b043b34d56774f73e436454e499f22f8d7cc3f2262a01866d8e55ef9ea3be9195fe48755ebfb015fbb992d SHA512 864b58319a8ff84bd6a94490eea9d89de800dcad678302df1ea4f834f27b5b18a5f8c0ac8ae57bd0c23d3c0904e99a90a0d363abfc39442bef5b55a70783ec1e
+EBUILD graylog2-2.5.1.ebuild 2288 BLAKE2B f973d7f05566ec7216b298cc374a699793f9935b0ced36989259a9b7c4c8bf55c8ec50193b461d15f7429ee4e645647cca5e76f821ea5d6d40e089db0372ab10 SHA512 06424941cb8918bffbbe477c1c3ff8edb23d6505597f20a8805a27db1c2c84f7f55bdcd65d81d808408c5ea43a4a8bed4a68e211d2076ec691fb31e9900c8aa4
MISC metadata.xml 251 BLAKE2B d6cd51cc02ac1322483c5ab4655173de8b1c64bac285b55a47fa3a35d3995eef653829b7cb110488c156247cff12381888fcd3b1fe248c8f5e3feb059c490b9f SHA512 7ea734b9e52a4e36b11e004da4a8178aa529574adee2129ba57b1ce75fd5017431fdfffe7a4a536c798ae645497a44b07c748d77308325cf4d6af070ff167edd
diff --git a/app-admin/graylog2/graylog2-2.5.1.ebuild b/app-admin/graylog2/graylog2-2.5.1.ebuild
new file mode 100644
index 000000000000..b4ba9c0fe33e
--- /dev/null
+++ b/app-admin/graylog2/graylog2-2.5.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit user
+
+DESCRIPTION="Free and open source log management"
+HOMEPAGE="https://graylog.org"
+SRC_URI="https://packages.graylog2.org/releases/graylog/graylog-${PV}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="strip"
+
+RDEPEND="virtual/jdk:1.8"
+
+DOCS=(
+ COPYING README.markdown UPGRADING.rst
+)
+
+GRAYLOG_DATA_DIR="/var/lib/graylog2"
+GRAYLOG_INSTALL_DIR="/usr/share/graylog2"
+QA_PREBUILT="${GRAYLOG_INSTALL_DIR}/lib/sigar/libsigar*"
+
+S="${WORKDIR}/graylog-${PV}"
+
+pkg_setup() {
+ enewgroup graylog
+ enewuser graylog -1 -1 -1 graylog
+}
+
+src_prepare() {
+ default
+
+ # Stick to architecture of build host
+ if ! use amd64; then
+ rm -r lib/sigar/libsigar-amd64-*.so || die "Failed in removing AMD64 support libraries"
+ fi
+ if ! use ppc64; then
+ rm -r lib/sigar/libsigar-ppc64-*.so || die "Failed in removing PPC64 support libraries"
+ fi
+ if ! use x86; then
+ rm -r lib/sigar/libsigar-x86-*.so || die "Failed in removing X86 support libraries"
+ fi
+ # Currently unsupported platforms
+ # QA warning galore but testing/patches welcome
+ rm lib/sigar/libsigar-*freebsd*so \
+ lib/sigar/libsigar-*solaris*so \
+ lib/sigar/libsigar-*hpux*.sl \
+ lib/sigar/libsigar-*macosx*.dylib \
+ lib/sigar/libsigar-ia64-*.so \
+ lib/sigar/libsigar-ppc-*.so \
+ lib/sigar/libsigar-s390x*.so \
+ lib/sigar/*winnt* || die "Failed in removing unsupported platform libraries"
+
+ # gentoo specific paths
+ sed -i "s@\(node_id_file = \).*@\1${GRAYLOG_DATA_DIR}/node-id@g; \
+ s@\(message_journal_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/journal@g; \
+ s@#\(content_packs_dir = \).*@\1${GRAYLOG_DATA_DIR}/data/contentpacks@g" \
+ graylog.conf.example || die
+}
+
+src_install() {
+ default
+
+ insinto /etc/graylog2
+ doins graylog.conf.example
+
+ insinto "${GRAYLOG_DATA_DIR}/data/contentpacks"
+ doins data/contentpacks/grok-patterns.json
+
+ insinto "${GRAYLOG_INSTALL_DIR}"
+ doins graylog.jar
+ doins -r lib plugin
+
+ newconfd "${FILESDIR}/confd-r2" graylog2
+ newinitd "${FILESDIR}/initd-r2" graylog2
+}
+
+pkg_postinst() {
+ ewarn "Graylog does not depend on need.net any more (#439092)."
+ ewarn
+ ewarn "Please configure rc_need according to your binding address in:"
+ ewarn "/etc/conf.d/graylog2"
+}